summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbacbbe40e15..366488a06525 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = python-skorch
pkgdesc = A scikit-learn compatible neural network library that wraps pytorch
- pkgver = 0.5.0
+ pkgver = 0.12.0
pkgrel = 1
- url = https://github.com/dnouri/skorch
+ url = https://github.com/skorch-dev/skorch
arch = any
license = BSD3
makedepends = python-setuptools
- depends = python-scikit-learn
- depends = python-yaml
depends = python-numpy
- depends = python-scipy
- depends = python-tqdm
depends = python-pytorch
+ depends = python-scikit-learn
+ depends = python-scipy
depends = python-tabulate
- source = https://github.com/dnouri/skorch/archive/v0.5.0.tar.gz
- sha256sums = ef1656d99c46ebb8d801f16d25ebc9dc52fa1781e44536018c73226c85f37fe3
+ depends = python-tqdm
+ depends = python-yaml
+ source = https://github.com/skorch-dev/skorch/archive/v0.12.0.tar.gz
+ sha256sums = 847c505553067efb2475793b968080564e6e9a96683a1012ccf40a32accab477
pkgname = python-skorch
-
diff --git a/PKGBUILD b/PKGBUILD
index 1154afcb211d..762bc3705091 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,24 @@
# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
_pkgname=skorch
pkgname=python-$_pkgname
-pkgver=0.5.0
+pkgver=0.12.0
pkgrel=1
pkgdesc="A scikit-learn compatible neural network library that wraps pytorch"
arch=('any')
-url="https://github.com/dnouri/skorch"
+url="https://github.com/skorch-dev/skorch"
license=('BSD3')
-depends=('python-scikit-learn' 'python-yaml' 'python-numpy' 'python-scipy' 'python-tqdm' 'python-pytorch' 'python-tabulate')
+depends=(
+ 'python-numpy'
+ 'python-pytorch'
+ 'python-scikit-learn'
+ 'python-scipy'
+ 'python-tabulate'
+ 'python-tqdm'
+ 'python-yaml'
+)
makedepends=('python-setuptools')
-source=("https://github.com/dnouri/skorch/archive/v${pkgver}.tar.gz")
-sha256sums=('ef1656d99c46ebb8d801f16d25ebc9dc52fa1781e44536018c73226c85f37fe3')
+source=("https://github.com/skorch-dev/skorch/archive/v${pkgver}.tar.gz")
+sha256sums=('847c505553067efb2475793b968080564e6e9a96683a1012ccf40a32accab477')
package() {
cd "$srcdir/$_pkgname-$pkgver"