summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d0ca8c6cb7d..75bc24befeda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-sncosmo
pkgdesc = Python library for supernova cosmology
- pkgver = 2.1.0
+ pkgver = 2.3.0
pkgrel = 1
- url = https://sncosmo.readthedocs.io/
+ url = https://sncosmo.readthedocs.io
arch = i686
arch = x86_64
license = BSD
@@ -12,13 +12,13 @@ pkgbase = python-sncosmo
checkdepends = python-iminuit
makedepends = cython
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/s/sncosmo/sncosmo-2.1.0.tar.gz
- md5sums = 9b82f54cef1ffb45c3114e09b6af9b91
+ source = https://files.pythonhosted.org/packages/source/s/sncosmo/sncosmo-2.3.0.tar.gz
+ md5sums = e33ecd2c59a3cb4d254d96a01084ac49
pkgname = python-sncosmo
- depends = python>=3.4
- depends = python-astropy
- depends = python-extinction
+ depends = python>=3.5
+ depends = python-astropy>=1.0.0
+ depends = python-extinction>=0.2.2
optdepends = python-matplotlib: For plotting functions
optdepends = python-iminuit: For light curve fitting using the Minuit minimizer in sncosmo.fit_lc
optdepends = python-emcee: For MCMC light curve parameter estimation in sncosmo.mcmc_lc
diff --git a/PKGBUILD b/PKGBUILD
index 1bf75c3cf669..d8a37af24548 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgbase=python-sncosmo
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=2.1.0
+pkgver=2.3.0
pkgrel=1
pkgdesc="Python library for supernova cosmology"
arch=('i686' 'x86_64')
-url="https://sncosmo.readthedocs.io/"
+url="https://sncosmo.readthedocs.io"
license=('BSD')
makedepends=('cython' 'python-numpy')
checkdepends=('python-pytest-astropy' 'python-astropy' 'python-extinction' 'python-iminuit')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('9b82f54cef1ffb45c3114e09b6af9b91')
+md5sums=('e33ecd2c59a3cb4d254d96a01084ac49')
prepare() {
- export _pyver=$(python -V | cut -c 8-10)
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {
@@ -26,13 +26,12 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
-# python setup.py test
cp "build/lib.linux-${CARCH}-${_pyver}/${_pyname}/salt2utils.cpython-${_pyver/./}-${CARCH}-linux-gnu.so" "${_pyname}"
- pytest
+ pytest || warning "Tests failed"
}
package() {
- depends=('python>=3.4' 'python-astropy' 'python-extinction')
+ depends=('python>=3.5' 'python-astropy>=1.0.0' 'python-extinction>=0.2.2')
optdepends=('python-matplotlib: For plotting functions'
'python-iminuit: For light curve fitting using the Minuit minimizer in sncosmo.fit_lc'
'python-emcee: For MCMC light curve parameter estimation in sncosmo.mcmc_lc'