summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8869b2352a9..8ab4c8df5a45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-social-auth-core
pkgdesc = Python Social Auth core component
- pkgver = 4.3.0
+ pkgver = 4.4.2
pkgrel = 1
url = https://github.com/python-social-auth/social-core
arch = any
@@ -14,7 +14,7 @@ pkgbase = python-social-auth-core
depends = python-openid
depends = python-cryptography
depends = python3-saml
- source = python-social-auth-core-4.3.0.tar.gz::https://github.com/python-social-auth/social-core/archive/4.3.0.tar.gz
- sha256sums = baf792268f4a928cd5f02bd538e7b6f80af493411e1ea223f0a98d50dd894d03
+ source = python-social-auth-core-4.4.2.tar.gz::https://github.com/python-social-auth/social-core/archive/4.4.2.tar.gz
+ sha256sums = 0c56c3d7e5bdc8fddfcfe9f7a82f7d56d83bb378cd9898fd779c8ba804662e89
pkgname = python-social-auth-core
diff --git a/PKGBUILD b/PKGBUILD
index 276a53de877a..1343d8c3d40a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Peter Mattern <pmattern at arcor dot de>
pkgname=python-social-auth-core
-pkgver=4.3.0
+pkgver=4.4.2
pkgrel=1
pkgdesc='Python Social Auth core component'
arch=('any')
@@ -12,7 +12,7 @@ depends=('python-six' 'python-defusedxml' 'python-pyjwt' 'python-jose' 'python-r
'python-openid' 'python-cryptography' 'python3-saml')
makedepends=('python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('baf792268f4a928cd5f02bd538e7b6f80af493411e1ea223f0a98d50dd894d03')
+sha256sums=('0c56c3d7e5bdc8fddfcfe9f7a82f7d56d83bb378cd9898fd779c8ba804662e89')
build() {
cd social-core-"${pkgver}"
@@ -27,4 +27,6 @@ package() {
install -Dm644 "${srcdir}/social-core-${pkgver}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ rm -rf "${pkgdir}/usr/lib/python3.11/site-packages/social_core/tests"
}