summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3240a22ecf6..aefe5b037170 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = python-soundcard
pkgdesc = Play and record audio without resorting to CPython extensions
- pkgver = 0.4.1
+ pkgver = 0.4.2
pkgrel = 1
url = https://github.com/bastibe/soundcard
arch = any
license = BSD
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = pulseaudio
depends = python-cffi
depends = python-numpy
- source = python-soundcard-0.4.1.tar.gz::https://github.com/bastibe/soundcard/archive/0.4.1.tar.gz
- sha512sums = e596fda839570234e2f858a8b871edb0471c6c2b2ada248bd63ec284217c52e6255c620a0d26a69ec89f70a6b1d06a77ebdd54a7bc949dab93d6543e664f7569
+ source = python-soundcard-0.4.2.tar.gz::https://github.com/bastibe/soundcard/archive/0.4.2.tar.gz
+ sha256sums = 3457c474a281d67f773e1ddd0f340032f23789e30280d2cb3f7cf2b08769c303
pkgname = python-soundcard
diff --git a/PKGBUILD b/PKGBUILD
index b8329d9b2fa9..9036b9323b9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Jonas Heinrich <onny@project-insantiy.org>
## license not available in pypi source package
pkgname=python-soundcard
-pkgver=0.4.1
+_pkg=SoundCard
+pkgver=0.4.2
pkgrel=1
pkgdesc='Play and record audio without resorting to CPython extensions'
-arch=(any)
+arch=('any')
url='https://github.com/bastibe/soundcard'
license=('BSD')
depends=('pulseaudio' 'python-cffi' 'python-numpy')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('e596fda839570234e2f858a8b871edb0471c6c2b2ada248bd63ec284217c52e6255c620a0d26a69ec89f70a6b1d06a77ebdd54a7bc949dab93d6543e664f7569')
+sha256sums=('3457c474a281d67f773e1ddd0f340032f23789e30280d2cb3f7cf2b08769c303')
build() {
- cd "SoundCard-$pkgver"
- python setup.py build
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "SoundCard-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm 644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/$_pkg-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}