summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d8d4cf6e464..c3240a22ecf6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-soundcard
pkgdesc = Play and record audio without resorting to CPython extensions
- pkgver = 0.3.3
+ pkgver = 0.4.1
pkgrel = 1
- url = https://github.com/bastibe/SoundCard
+ url = https://github.com/bastibe/soundcard
arch = any
- license = BSD3
+ license = BSD
makedepends = python-setuptools
- depends = python
- source = https://files.pythonhosted.org/packages/c3/31/b6098569bbb551b67a8631ba1197a037ad66c7795198f8dcc194a60fc053/SoundCard-0.3.3.tar.gz
- sha512sums = fa8c76356098bfb6c0002ab3a9305cc43f4022b23578f45157294fda25cc99fa1c08c2479ff7762b1952615807f13959943f51ef9e1c944587391c26039d3d82
+ depends = pulseaudio
+ depends = python-cffi
+ depends = python-numpy
+ source = python-soundcard-0.4.1.tar.gz::https://github.com/bastibe/soundcard/archive/0.4.1.tar.gz
+ sha512sums = e596fda839570234e2f858a8b871edb0471c6c2b2ada248bd63ec284217c52e6255c620a0d26a69ec89f70a6b1d06a77ebdd54a7bc949dab93d6543e664f7569
pkgname = python-soundcard
-
diff --git a/PKGBUILD b/PKGBUILD
index 295d5da6892a..b8329d9b2fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,28 @@
-# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
# Contributor: Jonas Heinrich <onny@project-insantiy.org>
+## license not available in pypi source package
+
pkgname=python-soundcard
-pkgver=0.3.3
+pkgver=0.4.1
pkgrel=1
pkgdesc='Play and record audio without resorting to CPython extensions'
arch=(any)
-url='https://github.com/bastibe/SoundCard'
-license=('BSD3')
-depends=('python')
+url='https://github.com/bastibe/soundcard'
+license=('BSD')
+depends=('pulseaudio' 'python-cffi' 'python-numpy')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/c3/31/b6098569bbb551b67a8631ba1197a037ad66c7795198f8dcc194a60fc053/SoundCard-${pkgver}.tar.gz")
-sha512sums=('fa8c76356098bfb6c0002ab3a9305cc43f4022b23578f45157294fda25cc99fa1c08c2479ff7762b1952615807f13959943f51ef9e1c944587391c26039d3d82')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('e596fda839570234e2f858a8b871edb0471c6c2b2ada248bd63ec284217c52e6255c620a0d26a69ec89f70a6b1d06a77ebdd54a7bc949dab93d6543e664f7569')
+
+build() {
+ cd "SoundCard-$pkgver"
+ python setup.py build
+}
package() {
- cd "SoundCard-${pkgver}"
- python setup.py install --root="$pkgdir"
+ cd "SoundCard-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
}