summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD21
3 files changed, 23 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c68310f97be..957563be3655 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-soundfile
pkgdesc = An audio library based on libsndfile, CFFI and NumPy
- pkgver = 0.10.1
+ pkgver = 0.10.2
pkgrel = 1
url = https://github.com/bastibe/PySoundFile
arch = any
@@ -9,8 +9,8 @@ pkgbase = python-soundfile
depends = python-cffi
depends = libsndfile
depends = python-numpy
- source = https://github.com/bastibe/PySoundFile/archive/0.10.1.tar.gz
- sha256sums = f53fc58b943827fee60e40ee87c11d1ff21cf6567c65449897371a4019be8c28
+ source = https://files.pythonhosted.org/packages/source/S/SoundFile/SoundFile-0.10.2.tar.gz
+ sha256sums = 637f6218c867b8cae80f6989634a0813b416b3e6132480d056e6e5a89a921571
pkgname = python-soundfile
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dd1a621b7eba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+SoundFile-*.tar.gz
+python-soundfile-*.pkg.tar.xz
+python-soundfile-*.src.tar.gz
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
index 74024310f321..8f252a699f05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,8 @@
+# Maintainer: Christopher Arndt <aur at chrisarndt dot de>
+
+_name=SoundFile
pkgname=python-soundfile
-pkgver=0.10.1
+pkgver=0.10.2
pkgrel=1
pkgdesc="An audio library based on libsndfile, CFFI and NumPy"
url="https://github.com/bastibe/PySoundFile"
@@ -7,17 +10,21 @@ arch=('any')
license=('BSD')
makedepends=('python-setuptools')
depends=('python-cffi' 'libsndfile' 'python-numpy')
-source=("https://github.com/bastibe/PySoundFile/archive/${pkgver}.tar.gz")
-sha256sums=('f53fc58b943827fee60e40ee87c11d1ff21cf6567c65449897371a4019be8c28')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('637f6218c867b8cae80f6989634a0813b416b3e6132480d056e6e5a89a921571')
+
build() {
- cd "${srcdir}"/SoundFile-$pkgver
+ cd "${srcdir}/${_name}-${pkgver}"
+
python setup.py build
}
package() {
- cd "${srcdir}/SoundFile-$pkgver"
- python setup.py install --root=${pkgdir} --optimize=1
-}
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+ # install license
+ install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
+}