summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26c26b4d1972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-sphinx-bootstrap-theme
+ pkgdesc = Sphinx documentation theme that integrates the Bootstrap framework
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = http://ryan-roemer.github.io/sphinx-bootstrap-theme/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/s/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.4.5.tar.gz
+ md5sums = 06ca1cb93aa7372e02815d43419b269c
+
+pkgname = python-sphinx-bootstrap-theme
+
+pkgname = python2-sphinx-bootstrap-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30ddfffe46cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Miguel de Val-Borro <miguel at archlinux dot net>
+pkgname=('python-sphinx-bootstrap-theme' 'python2-sphinx-bootstrap-theme')
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="Sphinx documentation theme that integrates the Bootstrap framework"
+arch=('any')
+url="http://ryan-roemer.github.io/sphinx-bootstrap-theme/"
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://pypi.python.org/packages/source/s/sphinx-bootstrap-theme/sphinx-bootstrap-theme-${pkgver}.tar.gz")
+md5sums=('06ca1cb93aa7372e02815d43419b269c')
+
+build() {
+ cp -r ${srcdir}/sphinx-bootstrap-theme-${pkgver} ${srcdir}/sphinx-bootstrap-theme-${pkgver}-py2
+
+ cd ${srcdir}/sphinx-bootstrap-theme-${pkgver}
+ python setup.py build
+
+ cd ${srcdir}/sphinx-bootstrap-theme-${pkgver}-py2
+ python2 setup.py build
+}
+
+package_python-sphinx-bootstrap-theme() {
+ cd ${srcdir}/sphinx-bootstrap-theme-${pkgver}
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ python setup.py install --prefix=/usr --root=${pkgdir}
+}
+
+package_python2-sphinx-bootstrap-theme() {
+ cd ${srcdir}/sphinx-bootstrap-theme-${pkgver}-py2
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+}