summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b87ef815c603..eb879519950f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = python-sphinx-gallery
pkgdesc = Sphinx extension to automatically generate an examples gallery
- pkgver = 0.11.0
+ pkgver = 0.11.1
pkgrel = 1
url = http://sphinx-gallery.github.io
arch = any
license = BSD
checkdepends = python-pytest-cov
checkdepends = python-matplotlib
- checkdepends = python-pillow
checkdepends = python-sphinx
checkdepends = python-absl
checkdepends = python-joblib
checkdepends = mayavi
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/s/sphinx-gallery/sphinx-gallery-0.11.0.tar.gz
- md5sums = c3adbd7c2e2315a72f9c8056feec2d7c
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-gallery/sphinx-gallery-0.11.1.tar.gz
+ md5sums = 34038a82a8dafd1f43dabc0a0968e210
pkgname = python-sphinx-gallery
- depends = python-sphinx>=1.8.3
+ depends = python-sphinx>=3
depends = python-pillow
depends = python-matplotlib
optdepends = python-seaborn
diff --git a/PKGBUILD b/PKGBUILD
index c676591965dc..a50661e3cb54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.11.0
+pkgver=0.11.1
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('any')
@@ -16,13 +16,13 @@ makedepends=('python-setuptools')
#'python-sphinx' 'python-pillow' 'python-scipy' 'python-seaborn')
checkdepends=('python-pytest-cov'
'python-matplotlib'
- 'python-pillow'
+# 'python-pillow'
'python-sphinx'
'python-absl'
'python-joblib'
'mayavi')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('c3adbd7c2e2315a72f9c8056feec2d7c')
+md5sums=('34038a82a8dafd1f43dabc0a0968e210')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -38,10 +38,11 @@ check() {
cd ${srcdir}/${_pyname}-${pkgver}
pytest || warning "Tests failed"
+# --deselect=sphinx_gallery/tests/test_scrapers.py::test_save_mayavi_figures || warning "Tests failed"
}
package_python-sphinx-gallery() {
- depends=('python-sphinx>=1.8.3' 'python-pillow' 'python-matplotlib')
+ depends=('python-sphinx>=3' 'python-pillow' 'python-matplotlib')
optdepends=('python-seaborn'
'mayavi'
'python-pypandoc')