summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 167eb194ec97..38b9a8639453 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = python-sphinx-gallery
pkgdesc = Sphinx extension to automatically generate an examples gallery
- pkgver = 0.12.2
+ pkgver = 0.13.0
pkgrel = 1
url = http://sphinx-gallery.github.io
arch = any
license = BSD
checkdepends = python-pytest-cov
+ checkdepends = python-exceptiongroup
checkdepends = python-matplotlib
checkdepends = python-pillow
checkdepends = python-sphinx
checkdepends = python-absl
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/s/sphinx-gallery/sphinx-gallery-0.12.2.tar.gz
- md5sums = 58a41686155b33abe26648aee8e88c40
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-gallery/sphinx-gallery-0.13.0.tar.gz
+ md5sums = 653078ba025b89a99171fe21417088b9
pkgname = python-sphinx-gallery
- depends = python-sphinx>=3
+ depends = python-sphinx>=4
depends = python-pillow
depends = python-matplotlib
optdepends = python-seaborn
diff --git a/PKGBUILD b/PKGBUILD
index c21cc6926d7c..3e0fc508a52c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-sphinx-gallery
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.12.2
+pkgver=0.13.0
pkgrel=1
pkgdesc="Sphinx extension to automatically generate an examples gallery"
arch=('any')
@@ -18,6 +18,7 @@ makedepends=('python-setuptools')
# 'python-scipy'
# 'python-seaborn')
checkdepends=('python-pytest-cov'
+ 'python-exceptiongroup'
'python-matplotlib'
'python-pillow'
'python-sphinx'
@@ -25,7 +26,7 @@ checkdepends=('python-pytest-cov'
# 'python-joblib'
# 'mayavi')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('58a41686155b33abe26648aee8e88c40')
+md5sums=('653078ba025b89a99171fe21417088b9')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -52,7 +53,7 @@ check() {
}
package_python-sphinx-gallery() {
- depends=('python-sphinx>=3' 'python-pillow' 'python-matplotlib')
+ depends=('python-sphinx>=4' 'python-pillow' 'python-matplotlib')
optdepends=('python-seaborn'
'mayavi'
'python-pypandoc')