summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42fbc2755ff8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-sphinx_rtd_theme-git
+ pkgdesc = Read the Docs theme for Sphinx
+ pkgver = 0.4.3.r22.gbad2112
+ pkgrel = 1
+ url = https://github.com/rtfd/sphinx_rtd_theme
+ arch = any
+ license = MIT
+ depends = python-setuptools
+ provides = python-sphinx_rtd_theme
+ conflicts = python-sphinx_rtd_theme
+ source = git+https://github.com/rtfd/sphinx_rtd_theme.git
+ sha512sums = SKIP
+
+pkgname = python-sphinx_rtd_theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f45461c968e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+# Contributor: Johannes Löthberg <johannes@kyriasis.com>
+# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
+# Contributor: Romain Schmitz <slopjong .at. slopjong .dot. de>
+
+pkgname=python-sphinx_rtd_theme-git
+pkgver=0.4.3.r22.gbad2112
+pkgrel=1
+pkgdesc='Read the Docs theme for Sphinx'
+url=https://github.com/rtfd/sphinx_rtd_theme
+arch=('any')
+license=('MIT')
+depends=('python-setuptools')
+provides=('python-sphinx_rtd_theme')
+conflicts=('python-sphinx_rtd_theme')
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${url##*/}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${url##*/}
+ ln -rsf fonts/{Lato,RobotoSlab} ${url##*/}/static/fonts
+}
+
+build() {
+ cd ${url##*/}
+ python setup.py build
+}
+
+package() {
+ cd ${url##*/}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}
+
+# vim:set ts=2 sw=2 et: