summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD23
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..123d2af2d001
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-sqlparse-0_3_0
+ pkgdesc = A non-validating SQL parser module for Python
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/andialbrecht/sqlparse
+ arch = any
+ license = BSD
+ makedepends = python-distribute
+ depends = python
+ provides = python-sqlparse
+ conflicts = python-sqlparse
+ conflicts = pyton-sqlparse-git
+ source = python-sqlparse-0.3.0.zip::https://github.com/andialbrecht/sqlparse/archive/0.3.0.zip
+ md5sums = 44e66ecc480fd4ac1309346c98e28e5b
+
+pkgname = python-sqlparse-0_3_0
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0045cadbfc4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.xz
+*.zip
+*.deb
+*.tar.gz
+*.tar.gz.asc
+*.tgz
+*.bz2
+/pkg
+/src
+*.gz
+rc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36e6338636e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: asm0dey <pavel.finkelshtein+AUR@gmail.com>
+
+pkgname=python-sqlparse-0_3_0
+_pkgname=python-sqlparse
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A non-validating SQL parser module for Python"
+url="https://github.com/andialbrecht/sqlparse"
+arch=(any)
+license=('BSD')
+depends=('python')
+makedepends=('python-distribute')
+source=($_pkgname-$pkgver.zip::https://github.com/andialbrecht/sqlparse/archive/$pkgver.zip)
+provides=('python-sqlparse')
+conflicts=('python-sqlparse' 'pyton-sqlparse-git')
+md5sums=('44e66ecc480fd4ac1309346c98e28e5b')
+
+package() {
+ cd "$srcdir/sqlparse-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p "$pkgdir/usr/share/licenses/$i_pkgname"
+ cp LICENSE "$_/LICENSE"
+}