summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c4b43ea635f..27b23edcfd47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=python-stomp.py
-pkgver=4.0.12
+_libname=${pkgname/python-/}
+pkgver=4.0.13
pkgrel=1
-pkgdesc="Python STOMP client, supporting versions 1.0 and 1.1 of the protocol"
+pkgdesc="Python STOMP client, supporting versions 1.0, 1.1 and 1.2 of the protocol"
arch=(any)
-url="http://code.google.com/p/stomppy"
-license=(Apache 2.0)
+url="https://github.com/jasonrbriggs/stomp.py"
+license=(Apache)
depends=(python)
-makedepends=('python-setuptools')
-source=("http://pypi.python.org/packages/source/s/stomp.py/stomp.py-$pkgver.tar.gz")
+source=(https://pypi.python.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz)
build() {
- cd "$srcdir/stomp.py-$pkgver"
- python setup.py build
+ cd "$srcdir"/$_libname-$pkgver
+ python setup.py build
}
package() {
- cd "$srcdir/stomp.py-$pkgver"
- python setup.py install -O1 --skip-build --root="$pkgdir"
- install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir"/$_libname-$pkgver
+ python setup.py install -O1 --skip-build --root="$pkgdir"
+ install -Dm0644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha256sums=('ce2a2293054600b4a1456e44828e60da29afa198bfa8fd85b9de74dfaef4231a')
+sha256sums=('c8edcb41beab667027cfe7865a434c5881532ab5a4059a88ae3df1dd5197184a')