summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD44
2 files changed, 32 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a185b13def3..0a8b7670387a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sunpy
pkgdesc = Python library for solar physics
- pkgver = 5.1.2
+ pkgver = 5.1.4
pkgrel = 1
url = https://sunpy.org
arch = i686
@@ -12,8 +12,8 @@ pkgbase = python-sunpy
makedepends = python-installer
makedepends = python-extension-helpers
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/s/sunpy/sunpy-5.1.2.tar.gz
- md5sums = 08dcb8c53fd8833e4ff8deac9806e437
+ source = https://files.pythonhosted.org/packages/source/s/sunpy/sunpy-5.1.4.tar.gz
+ md5sums = 95b74b9111a8525e7199ad3713862eff
pkgname = python-sunpy
depends = python>=3.9
diff --git a/PKGBUILD b/PKGBUILD
index f417ed47f930..40ada84ce9fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=python-sunpy
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=5.1.2
+pkgver=5.1.4
pkgrel=1
pkgdesc="Python library for solar physics"
arch=('i686' 'x86_64')
@@ -15,25 +15,34 @@ makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-insta
#'python-sunpy-sphinx-theme'
#'python-parfive' 'python-astroquery' 'python-reproject' 'python-ruamel-yaml' 'python-jplephem' 'python-sphinx-automodapi' 'python-sphinx-changelog' 'python-sphinx-gallery>=0.9.0' 'python-sphinxext-opengraph'
#'python-scikit-image' 'python-h5netcdf' 'python-sqlalchemy' 'python-lxml' 'python-zeep' 'python-drms' 'python-aioftp' 'python-asdf' 'python-cdflib' 'python-mpl-animators' 'graphviz')
-#checkdepends=('python-pytest-doctestplus'
+#checkdepends=('python-pytest-arraydiff'
+# 'python-pytest-doctestplus'
+# 'python-pytest-remotedata'
+# 'python-pytest-xdist'
+# 'python-pytest-mpl'
# 'python-pytest-mock'
# 'python-reproject'
-# 'python-aiohttp'
+# 'python-asdf-astropy'
# 'python-parfive'
-# 'python-matplotlib'
# 'python-scipy'
# 'python-beautifulsoup4'
+# 'python-pandas'
# 'python-lxml'
-# 'python-requests'
# 'python-zeep'
# 'python-drms'
# 'python-sqlalchemy'
# 'python-hypothesis'
# 'python-scikit-image'
# 'python-h5netcdf'
+# 'python-cdflib'
+# 'python-mpl-animators'
# 'python-glymur'
-# 'python-asdf'
-# 'python-mpl-animators')
+# 'python-hvpy'
+# 'python-opencv'
+# 'python-astroquery'
+# 'python-aioftp'
+# 'python-jplephem'
+#) # matplotlib <-mpl-animater, aiohttp <- parfive, asdf <- asdf-astropy
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
# "http://data.sunpy.org/sunpy/v1/AIA20110607_063301_0131_lowres.fits"
# "http://data.sunpy.org/sunpy/v1/AIA20110607_063302_0171_lowres.fits"
@@ -63,7 +72,7 @@ source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname
# "http://data.sunpy.org/sunpy/v1/aiacalibim5.fits.gz"
# "http://data.sunpy.org/sunpy/v1/glg_cspec_n5_110607_v00.pha")
## "http://netdrms01.nispdc.nso.edu/VSO/WSDL/VSOi_rpc_literal.wsdl")
-md5sums=('08dcb8c53fd8833e4ff8deac9806e437')
+md5sums=('95b74b9111a8525e7199ad3713862eff')
# 'bde3bd7a691b38e2e4c4e1d17b143b24'
# '01efaf052d81efc32a92050a249aa557'
# 'ead6d3ce4c183c471d76bf1bc3be44a3'
@@ -109,7 +118,7 @@ get_pyver() {
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation --skip-dependency-check
# msg "Building Docs"
# cd ${srcdir}/${_pyname}-${pkgver}/docs
@@ -127,12 +136,17 @@ build() {
# cd ${srcdir}/${_pyname}-${pkgver}
#
# ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname}*egg-info \
-# build/lib.linux-${CARCH}-$(get_pyver)/${_pyname}-${pkgver}-py$(get_pyver).egg-info
-# mkdir -p ${HOME}/.local/share/${_pyname}
-# ln -rs ${srcdir}/*.fit* ${HOME}/.local/share/${_pyname}
-# ln -rs ${srcdir}/*.txt ${HOME}/.local/share/${_pyname}
-# ln -rs ${srcdir}/*.pha ${HOME}/.local/share/${_pyname}
-# PYTHONPATH="build/lib.linux-${CARCH}-$(get_pyver)" pytest "build/lib.linux-${CARCH}-$(get_pyver)" #|| warning "Tests failed"
+# build/lib.linux-${CARCH}-cpython-$(get_pyver)/${_pyname}-${pkgver}-py$(get_pyver .).egg-info
+## mkdir -p ${HOME}/.local/share/${_pyname}
+## ln -rs ${srcdir}/*.fit* ${HOME}/.local/share/${_pyname}
+## ln -rs ${srcdir}/*.txt ${HOME}/.local/share/${_pyname}
+## ln -rs ${srcdir}/*.pha ${HOME}/.local/share/${_pyname}
+## PYTHONPATH="build/lib.linux-${CARCH}-$(get_pyver)" pytest "build/lib.linux-${CARCH}-$(get_pyver)" -vv -l -ra --color=yes -o console_output_style=count #|| warning "Tests failed" -vv -l -ra --color=yes -o console_output_style=count
+# # From NixOS, remove tests needs hvpy, spicepy
+# PYTHONPATH="build/lib.linux-${CARCH}-cpython-$(get_pyver)" pytest -vv -l -ra --color=yes -o console_output_style=count "build/lib.linux-${CARCH}-cpython-$(get_pyver)" docs --remote-data=any -p xdist -n 4 -Wdefault \
+# --ignore=build/lib.linux-${CARCH}-cpython-$(get_pyver)/sunpy/net/tests/test_fido.py \
+# --ignore=build/lib.linux-${CARCH}-cpython-$(get_pyver)/sunpy/coordinates/tests/test_spice.py #\
+# #|| warning "Tests failed" -vv -l -ra --color=yes -o console_output_style=count
#}
package_python-sunpy() {