summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
-rw-r--r--xrange.patch26
3 files changed, 23 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8921107da561..e6e65e4627fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,19 @@
pkgbase = python-svglib
pkgdesc = A pure-Python library for reading and converting SVG files.
- pkgver = 0.8.1
- pkgrel = 2
- url = http://pypi.python.org/pypi/svglib/0.8.1
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/svglib/1.0.0
arch = any
license = LGPL
makedepends = python-setuptools
- makedepends = python2-setuptools
+ depends = python
+ depends = python-lxml
+ depends = python-cssselect2
+ depends = python-tinycss2
+ depends = python-reportlab
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/s/svglib/svglib-0.8.1.tar.gz
- source = xrange.patch
- sha256sums = 1f8cb633f154b83987e3a906a55cf69c8739c0df5ea4eee024677c3e8fb62f55
- sha256sums = 21d9f9634ba0c92ee6b21c720978a3825ff92974177cab17e72015c62ec10a47
-
-pkgname = python2-svglib
- depends = python2
- depends = python2-reportlab
- depends = python2-lxml
+ source = https://files.pythonhosted.org/packages/source/s/svglib/svglib-1.0.0.tar.gz
+ sha256sums = b17d4a6352f6c25ca3718d2b66a2f1ecfcdf558b1f6646c37f5c191b655979f1
pkgname = python-svglib
- depends = python
- depends = python-reportlab
- depends = python-lxml
diff --git a/PKGBUILD b/PKGBUILD
index 92f6b27962c7..b68919e58b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,25 @@
-# Contributor: Vladimir Gorbunov <truedaemon@gmail.com>
+# Maintainer: Vladimir Gorbunov <truedaemon@gmail.com>
pkgbase=python-svglib
-pkgname=('python2-svglib' 'python-svglib')
+pkgname=('python-svglib')
_name=svglib
-pkgver=0.8.1
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
pkgdesc="A pure-Python library for reading and converting SVG files."
arch=('any')
url="http://pypi.python.org/pypi/svglib/$pkgver"
license=('LGPL')
options=(!emptydirs)
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- "xrange.patch")
-sha256sums=('1f8cb633f154b83987e3a906a55cf69c8739c0df5ea4eee024677c3e8fb62f55'
- '21d9f9634ba0c92ee6b21c720978a3825ff92974177cab17e72015c62ec10a47')
-
-prepare() {
- cd "$srcdir/svglib-$pkgver"
- # Fix python 3 compatibility
- patch -Np1 -i "${srcdir}/xrange.patch"
-}
-
-package_python2-svglib() {
- cd "$srcdir/svglib-$pkgver"
- depends=('python2' 'python2-reportlab' 'python2-lxml')
- python2 setup.py install --root="$pkgdir/" --optimize=1
- mv "${pkgdir}/usr/bin/svg2pdf" "${pkgdir}/usr/bin/svg2pdf-py2"
-}
+depends=('python'
+ 'python-lxml'
+ 'python-cssselect2'
+ 'python-tinycss2'
+ 'python-reportlab')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('b17d4a6352f6c25ca3718d2b66a2f1ecfcdf558b1f6646c37f5c191b655979f1')
package_python-svglib() {
- cd "$srcdir/svglib-$pkgver"
- depends=('python' 'python-reportlab' 'python-lxml')
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="$pkgdir/" --optimize=1
}
diff --git a/xrange.patch b/xrange.patch
deleted file mode 100644
index 0cdfa49e0952..000000000000
--- a/xrange.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -ura package.old/svglib/svglib.py package.new/svglib/svglib.py
---- package.old/svglib/svglib.py 2018-08-05 13:06:04.914558175 +0300
-+++ package.new/svglib/svglib.py 2018-08-05 13:06:38.733596856 +0300
-@@ -744,7 +744,7 @@
- subpath_start = []
- lastop = ''
-
-- for i in xrange(0, len(normPath), 2):
-+ for i in range(0, len(normPath), 2):
- op, nums = normPath[i:i+2]
-
- if op in ('m', 'M') and i > 0 and path.operators[-1] != _CLOSEPATH:
-Только в package.new/svglib: svglib.py~
-diff -ura package.old/svglib/utils.py package.new/svglib/utils.py
---- package.old/svglib/utils.py 2018-08-05 13:06:04.914558175 +0300
-+++ package.new/svglib/utils.py 2018-08-05 13:06:49.629953774 +0300
-@@ -196,7 +196,7 @@
-
- c1 = cos(theta1)
- s1 = sin(theta1)
-- for i in xrange(nfrag):
-+ for i in range(nfrag):
- c0 = c1
- s0 = s1
- theta1 = start_rad + i * frag_rad
-Только в package.new/svglib: utils.py~