summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 550922335853..802c85592fcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-swiglpk
- pkgdesc = A low-level Python interface to the GLPK optimization solver.
+ pkgdesc = A Python interface to the GLPK optimization solver.
pkgver = 4.65.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/biosustain/swiglpk
arch = any
license = GPL3
@@ -9,8 +9,9 @@ pkgbase = python-swiglpk
makedepends = python-setuptools
depends = python
depends = glpk
+ conflicts = python-swiglpk-git
source = https://github.com/biosustain/swiglpk/archive/4.65.1.tar.gz
- md5sums = 8d364cad69416cebd6e405b22f71c14d
+ md5sums = 1870f23fb67b60263ef1f7b343ab657b
pkgname = python-swiglpk
diff --git a/PKGBUILD b/PKGBUILD
index 7845caf9e668..190f84acab1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
pkgname=python-swiglpk
pkgver=4.65.1
-pkgrel=3
-pkgdesc='A low-level Python interface to the GLPK optimization solver.'
+pkgrel=4
+pkgdesc='A Python interface to the GLPK optimization solver.'
arch=('any')
url='https://github.com/biosustain/swiglpk'
license=('GPL3')
depends=('python' 'glpk')
makedepends=('swig' 'python-setuptools')
-
+conflicts=('python-swiglpk-git')
source=("https://github.com/biosustain/swiglpk/archive/${pkgver}.tar.gz")
+md5sums=('1870f23fb67b60263ef1f7b343ab657b')
prepare() {
cd "${srcdir}/swiglpk-${pkgver}"
@@ -19,9 +20,18 @@ prepare() {
cp /usr/include/glpk.h .
}
+build() {
+ cd "${srcdir}/swiglpk-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "${srcdir}/swiglpk-${pkgver}/build/lib."*
+ python -Bc "import swiglpk"
+}
+
package() {
cd "${srcdir}/swiglpk-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
-md5sums=('8d364cad69416cebd6e405b22f71c14d')