summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5dc0a626daf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-swyft
+ pkgdesc = swyft is the official implementation of Truncated Marginal Neural Ratio Estimation (TMNRE), a hyper-efficient, simulation-based inference technique for complex data and expensive simulators.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/undark-lab/swyft
+ arch = any
+ license = Apache
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python-toolz
+ depends = python-numpy
+ depends = python-torch
+ depends = python-pytorch_lightning
+ depends = python-zarr
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-torchist
+ depends = python-fasteners
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/s/swyft/swyft-0.4.1.tar.gz
+ sha256sums = 5b19514d6a114f7a768e96240026091db87a68495e1c43a212acf3dd842fd3e2
+
+pkgname = python-swyft
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6b8c850ccb9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+*.tar.zst
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7791a0d6c280
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=python-swyft
+_name=${pkgname#python-}
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="swyft is the official implementation of Truncated Marginal Neural Ratio Estimation (TMNRE), a hyper-efficient, simulation-based inference technique for complex data and expensive simulators."
+arch=(any)
+url="https://github.com/undark-lab/swyft"
+license=('Apache')
+groups=()
+depends=(python-toolz python-numpy python-torch python-pytorch_lightning python-zarr python-matplotlib python-scipy python-torchist python-fasteners)
+makedepends=(python-build python-installer)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(5b19514d6a114f7a768e96240026091db87a68495e1c43a212acf3dd842fd3e2)
+
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+