summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD60
-rw-r--r--requirements-versions.patch21
3 files changed, 68 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d9a32a62d3b..6db5096fbce6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-syncthing
pkgdesc = Python bindings to the Syncthing REST interface
- pkgver = 2.3.1
+ pkgver = 2.4.2
pkgrel = 1
url = https://github.com/blakev/python-syncthing
arch = any
- license = GPL
- depends = syncthing
+ license = MIT
+ makedepends = python-setuptools
depends = python
- depends = python-requests
depends = python-dateutil
- options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/s/syncthing/syncthing-2.3.1.tar.gz
- md5sums = ead41fbbc898fa53d276261b490d5b45
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/source/s/syncthing/syncthing-2.4.2.tar.gz
+ source = requirements-versions.patch
+ b2sums = 9967dfd954b8f31ab3aa492d29c6aeddfa5b4fb9b1853ac8d4a18944f8f43a91b6ed867e7230867b7ebbb81a765c88daddbee8fbb7ee16c0cb2f2106cdc503f0
+ b2sums = 93365beee887e2056a1d74533a1970287a2fca70fd0059e4372b78f3a238762a6c2c455a4985e00ce46cc27542df495debf33828625346351cf511258c3b05b8
pkgname = python-syncthing
-
diff --git a/PKGBUILD b/PKGBUILD
index 84f436a8ff96..9b0f49d44cfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,46 @@
-# Maintainer: Doron Behar <doron.behar@gmail.com>
+# Maintainer: peippo <christoph+aur@christophfink.com>
pkgname=python-syncthing
-_name=syncthing
-pkgver=2.3.1
-pkgrel=1
+_name=${pkgname#python-}
pkgdesc="Python bindings to the Syncthing REST interface"
-arch=('any')
url="https://github.com/blakev/python-syncthing"
-license=('GPL')
-groups=()
-depends=('syncthing' 'python' 'python-requests' 'python-dateutil')
-makedepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('ead41fbbc898fa53d276261b490d5b45')
-package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+pkgver=2.4.2
+pkgrel=1
+
+arch=("any")
+license=("MIT")
+
+makedepends=(
+ "python-setuptools"
+)
+depends=(
+ "python"
+ "python-dateutil"
+ "python-requests"
+)
+
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "requirements-versions.patch"
+)
+b2sums=('9967dfd954b8f31ab3aa492d29c6aeddfa5b4fb9b1853ac8d4a18944f8f43a91b6ed867e7230867b7ebbb81a765c88daddbee8fbb7ee16c0cb2f2106cdc503f0'
+ '93365beee887e2056a1d74533a1970287a2fca70fd0059e4372b78f3a238762a6c2c455a4985e00ce46cc27542df495debf33828625346351cf511258c3b05b8')
+
+prepare() {
+ cd "${srcdir}"/${_name}-${pkgver}
+ patch --forward --strip=1 --input "${srcdir}/requirements-versions.patch"
}
-# vim:set ts=2 sw=2 et:
+build() {
+ cd "${srcdir}"/${_name}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
diff --git a/requirements-versions.patch b/requirements-versions.patch
new file mode 100644
index 000000000000..0527aa0cc6bb
--- /dev/null
+++ b/requirements-versions.patch
@@ -0,0 +1,21 @@
+diff --unified --recursive --text a/setup.py b/setup.py
+--- a/setup.py 2023-05-16 11:25:58.026066441 +0300
++++ b/setup.py 2023-05-16 11:26:20.499671832 +0300
+@@ -12,8 +12,8 @@
+ url = 'https://github.com/blakev/python-syncthing',
+ license = 'The MIT License',
+ install_requires = [
+- 'python-dateutil==2.8.1',
+- 'requests==2.24.0'
++ 'python-dateutil',
++ 'requests'
+ ],
+ extras_require = {
+ 'dev': [
+@@ -44,4 +44,4 @@
+ 'Programming Language :: Python :: 3.8',
+ 'Topic :: System :: Archiving :: Mirroring'
+ ],
+-)
+\ No newline at end of file
++)