summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--0001-Use-system-tdlib.diff27
-rw-r--r--0002-Remove-binarys.diff15
-rw-r--r--PKGBUILD16
4 files changed, 11 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cb539e03531..76f565ca6b09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = python-telegram
pkgdesc = Python API for the tdlib library. It helps you build your own Telegram clients.
- pkgver = 0.15.0
- pkgrel = 2
+ pkgver = 0.16.0
+ pkgrel = 1
url = https://github.com/alexander-akhmetov/python-telegram
arch = any
license = MIT
depends = python3
- depends = libtd>=1.7.9
+ depends = libtd>=1.8.5
+ depends = python-setuptools
conflicts = python-telegram-bot
- source = python-telegram-0.15.0.tar.gz::https://github.com/alexander-akhmetov/python-telegram/archive/0.15.0.tar.gz
- source = 0001-Use-system-tdlib.diff
- source = 0002-Remove-binarys.diff
- md5sums = 860bf09e9ac3e9009d9947a01dde6f88
- md5sums = 287acb342038ba44bb86cdc2c6cb303b
- md5sums = c9085c229e25cab11bffd1431c220ef1
+ source = python-telegram-0.16.0.tar.gz::https://github.com/alexander-akhmetov/python-telegram/archive/0.16.0.tar.gz
+ md5sums = ce8958353e5d87b213c38d0b21d59813
pkgname = python-telegram
diff --git a/0001-Use-system-tdlib.diff b/0001-Use-system-tdlib.diff
deleted file mode 100644
index a5f9340cc6df..000000000000
--- a/0001-Use-system-tdlib.diff
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/telegram/tdjson.py b/telegram/tdjson.py
-index 091145e..21c0361 100644
---- a/telegram/tdjson.py
-+++ b/telegram/tdjson.py
-@@ -2,6 +2,7 @@ import json
- import logging
- import platform
- from ctypes import CDLL, CFUNCTYPE, c_int, c_char_p, c_double, c_void_p, c_longlong
-+from ctypes.util import find_library
- from typing import Any, Dict, Optional, Union
-
- import pkg_resources
-@@ -10,13 +11,7 @@ logger = logging.getLogger(__name__)
-
-
- def _get_tdjson_lib_path() -> str:
-- if platform.system().lower() == 'darwin':
-- lib_name = 'darwin/libtdjson.dylib'
-- else:
-- lib_name = 'linux/libtdjson.so'
--
-- return pkg_resources.resource_filename('telegram', f'lib/{lib_name}')
--
-+ return find_library("tdjson")
-
- class TDJson:
- def __init__(self, library_path: Optional[str] = None, verbosity: int = 2) -> None:
diff --git a/0002-Remove-binarys.diff b/0002-Remove-binarys.diff
deleted file mode 100644
index 72b1744dfb54..000000000000
--- a/0002-Remove-binarys.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/setup.py b/setup.py
-index a1ac7b0..aecc107 100644
---- a/setup.py
-+++ b/setup.py
-@@ -25,10 +25,4 @@ setup(
- packages=[
- 'telegram',
- ],
-- package_data={
-- 'telegram': [
-- 'lib/darwin/*',
-- 'lib/linux/*',
-- ],
-- },
- )
diff --git a/PKGBUILD b/PKGBUILD
index 84644eddd13a..c5307f7ff836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,18 @@
# Maintainer: j.r <j.r@jugendhacker.de>
pkgname=python-telegram
-pkgver=0.15.0
-pkgrel=2
+pkgver=0.16.0
+pkgrel=1
pkgdesc="Python API for the tdlib library. It helps you build your own Telegram clients."
arch=(any)
url="https://github.com/alexander-akhmetov/python-telegram"
license=('MIT')
-depends=('python3' 'libtd>=1.7.9')
+depends=('python3' 'libtd>=1.8.5' 'python-setuptools')
conflicts=('python-telegram-bot')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/alexander-akhmetov/$pkgname/archive/$pkgver.tar.gz"
- "0001-Use-system-tdlib.diff"
- "0002-Remove-binarys.diff")
-md5sums=('860bf09e9ac3e9009d9947a01dde6f88'
- '287acb342038ba44bb86cdc2c6cb303b'
- 'c9085c229e25cab11bffd1431c220ef1')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/alexander-akhmetov/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('ce8958353e5d87b213c38d0b21d59813')
prepare() {
cd "${pkgname}-${pkgver}"
- patch -p1 -i ${srcdir}/0001-Use-system-tdlib.diff
- patch -p1 -i ${srcdir}/0002-Remove-binarys.diff
rm -r telegram/lib
}