summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a097e1fb8c5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Dec 12 21:52:24 UTC 2018
+pkgbase = python-telegramusermapbot-git
+ pkgdesc = A Telegram Bot to collect location information from users and export the coordinates to a map service.
+ pkgver = r29.e2ab1e7
+ pkgrel = 1
+ url = https://github.com/Thaodan/TelegramUserMapBot
+ arch = any
+ license = GPL3
+ depends = python-peewee
+ depends = python-telegram-bot
+ source = git+https://github.com/Thaodan/TelegramUserMapBot#branch=merger
+ md5sums = SKIP
+
+pkgname = python-telegramusermapbot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c49a1c85583e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Thaodan <theodorstormgrade@gmai.com>
+_pkgname=TelegramUserMapBot
+pkgname=python-${_pkgname,,}-git
+pkgrel=1
+pkgver=r29.e2ab1e7
+pkgdesc="A Telegram Bot to collect location information from users and export the coordinates to a map service."
+url="https://github.com/Thaodan/$_pkgname"
+arch=('any')
+license=('GPL3')
+depends=('python-peewee' 'python-telegram-bot')
+source=(git+https://github.com/Thaodan/$_pkgname#branch=merger)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm755 $_pkgname.service "$pkgdir"/usr/lib/systemd/system/$_pkgname.service
+ install -dm755 "$pkgdir"/etc/_$pkgname
+}
+md5sums=('SKIP')