summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1391ad1e2d8..8d18b2c61d50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-telethon
pkgdesc = Full-featured Telegram client library for Python 3
- pkgver = 1.29.0
+ pkgver = 1.29.1
pkgrel = 1
url = https://github.com/LonamiWebs/Telethon
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-telethon
makedepends = python-setuptools
depends = python-pyaes
depends = python-rsa
- source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.29.0.tar.gz
- sha256sums = 0237669d517fbf095fe548a654b324e342f7be1967ec82d295677acdda99dc8f
+ source = https://files.pythonhosted.org/packages/source/T/Telethon/Telethon-1.29.1.tar.gz
+ sha256sums = 47bcdfa9161ac39c8833f25967b2fa9388cde2dd6b96219b7552b55f413d1972
pkgname = python-telethon
diff --git a/PKGBUILD b/PKGBUILD
index 420bcc0c59a1..b7dd3ee9e247 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.29.0
+pkgver=1.29.1
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.29.0.tar.gz")
-sha256sums=('0237669d517fbf095fe548a654b324e342f7be1967ec82d295677acdda99dc8f')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.29.1.tar.gz")
+sha256sums=('47bcdfa9161ac39c8833f25967b2fa9388cde2dd6b96219b7552b55f413d1972')
build() {
- cd "$srcdir/Telethon-1.29.0"
+ cd "$srcdir/Telethon-1.29.1"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.29.0"
+ cd "$srcdir/Telethon-1.29.1"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files