summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD39
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15da1e7e1c7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-term-background
+ pkgdesc = Python module to align a simple (not nested) list in columns.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/rocky/shell-term-background
+ arch = any
+ license = GPLv2
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ source = python-term-background-1.0.1.tar.gz::https://github.com/rocky/shell-term-background/refs/tags/1.0.1.tar.gz
+ sha256sums = c59081defac311e078657b0e7e933970a57fc89a4ba152d159436ccc3b6477a8
+
+pkgname = python-term-background
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7f2fa6a2e01c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Tars
+python-term-background*.tar.gz
+*.pkg.tar.zst
+
+# makepkg
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00f6ab36066a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Techcable <Techcable at techcable dot net>
+pkgname=python-term-background
+pkgver=1.0.1
+pkgrel=1
+epoch=
+pkgdesc="Python module to align a simple (not nested) list in columns."
+arch=("any")
+_reponame="shell-term-background" # Why is it called 'shell' instead of 'python'?
+url="https://github.com/rocky/shell-term-background"
+license=("GPLv2")
+groups=()
+depends=()
+makedepends=("python-setuptools")
+checkdepends=("python-pytest")
+backup=() # Anything we need to backup?
+options=()
+install=
+changelog=
+source=("${pkgname}-${pkgver}.tar.gz::${url}/refs/tags/${pkgver}.tar.gz")
+sha256sums=("c59081defac311e078657b0e7e933970a57fc89a4ba152d159436ccc3b6477a8")
+
+prepare() {
+ true; # Nothing to do I guess
+}
+
+build() {
+ cd "${_reponame}-$pkgver"
+ python3 ./setup.py build;
+}
+
+check() {
+ cd "${_reponame}-$pkgver"
+ PYTHONPATH="." pytest test;
+}
+
+package() {
+ cd "${_reponame}-$pkgver"
+ python setup.py install --root="$pkgdir/" --prefix="/usr"
+}