summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
-rw-r--r--theHarvester.install3
4 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0a1967ff627..9daf27963b16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = python-theharvester-git
pkgdesc = A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers).
- pkgver = 3.0.6.r421.g9f7811d
+ pkgver = 3.0.6.r424.g838892e
pkgrel = 1
- url = https://github.com/laramies/theHarvester
+ url = https://github.com/ssolidus/theHarvester
install = theHarvester.install
arch = any
license = GPL2
makedepends = git
- makedepends = bash
- depends = bash
- depends = python-setuptools
+ makedepends = python-setuptools
depends = python
depends = python-yaml
depends = python-requests
diff --git a/.gitignore b/.gitignore
index 4e8e0f6c2013..cc4134bb0302 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ python-theharvester-git-*
python-theharvester-git/
src/
stash.sqlite
+theHarvester/
diff --git a/PKGBUILD b/PKGBUILD
index 9a553469bf60..134a8c468c30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Sebastian Neef <aur AT gehaxelt DOT IN>
+# Maintainer: ocelot <amitchell AT airmail DOT cc>
pkgbase=python-theharvester-git
pkgname=python-theharvester-git
-pkgver=3.0.6.r421.g9f7811d
+pkgver=3.0.6.r424.g838892e
pkgrel=1
pkgdesc="A tool for gathering e-mail accounts, subdomain names, virtual hosts, open ports/ banners, and employee names from different public sources (search engines, pgp key servers)."
arch=('any')
-url="https://github.com/laramies/theHarvester"
+url="https://github.com/ssolidus/theHarvester"
license=('GPL2')
depends=(
'python'
@@ -39,7 +39,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}"
- python setup.py install --user --root=${pkgdir} --optimize=1 --skip-build
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
}
check(){
diff --git a/theHarvester.install b/theHarvester.install
index 7a417b072ae8..0daed8c87338 100644
--- a/theHarvester.install
+++ b/theHarvester.install
@@ -1,6 +1,7 @@
post_install() {
echo "IMPORTANT: The location of API keys has changed!"
- echo "Add your keys to /opt/theharvester-git/api-keys.yaml"
+ echo "Add your keys to <CURRENT-DIRECTORY>/api-keys.yml"
+ echo "This will change to a more appropriate location in the future."
echo " bingapi"
echo " hunter"
echo " intelx"