summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7e545248f5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-timbl-git
+ pkgdesc = Python binding for Timbl, a k-Nearest Neighbours machine learning suite
+ pkgver = 48
+ pkgrel = 1
+ url = https://github.com/proycon/python-timbl
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = libtool
+ depends = python
+ depends = libxml2
+ depends = boost
+ depends = timbl
+ depends = python-setuptools
+ provides = python-timbl
+ source = git://github.com/proycon/python-timbl.git
+ md5sums = SKIP
+
+pkgname = python-timbl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e36fa24a002
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+_pkgname=python-timbl
+pkgname=${_pkgname}-git
+pkgver=48
+pkgrel=1
+pkgdesc='Python binding for Timbl, a k-Nearest Neighbours machine learning suite'
+arch=('i686' 'x86_64')
+url="https://github.com/proycon/python-timbl"
+license=('GPL')
+depends=('python' 'libxml2' 'boost' 'timbl' 'python-setuptools')
+makedepends=('git' 'libtool')
+provides=("${_pkgname}")
+source=("git://github.com/proycon/python-timbl.git")
+_gitname=("python-timbl")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git rev-list --count HEAD
+}
+
+
+build() {
+ cd "$srcdir/$_gitname"
+ python setup3.py build_ext --timbl-library-dir=/usr/lib --timbl-include-dir=/usr/include/ build
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup3.py build_ext --timbl-library-dir=/usr/lib --timbl-include-dir=/usr/include/ install --prefix=/usr --root="${pkgdir}"
+}