summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD16
3 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a55cc00d73e..56d4a538b1d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-tinyrecord
pkgdesc = Atomic transactions for TinyDB
- pkgver = 0.2.1
- pkgrel = 2
+ pkgver = 0.2.1.r6.g96223e9
+ pkgrel = 1
url = https://github.com/eugene-eeo/tinyrecord
arch = any
license = MIT
@@ -12,8 +12,7 @@ pkgbase = python-tinyrecord
makedepends = python-wheel
makedepends = git
depends = python-tinydb
- source = python-tinyrecord::git+https://github.com/eugene-eeo/tinyrecord#commit=6affc18?signed
- validpgpkeys = BB354D48E3A3B416AC1242CB517D153BDE152D17
+ source = python-tinyrecord::git+https://github.com/eugene-eeo/tinyrecord#commit=96223e9f472ef3353aa3c4a63d1e46501edd8452
sha256sums = SKIP
pkgname = python-tinyrecord
diff --git a/.gitignore b/.gitignore
index 924dfb95c209..e4f9ba3007cf 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
-pkg/
-src/
-*.tar.*
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 7bf37c634a8d..6218267408c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: a821
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=python-tinyrecord
-_pkg="${pkgname#python-}"
-pkgver=0.2.1
-pkgrel=2
+pkgver=0.2.1.r6.g96223e9
+_commit=96223e9f472ef3353aa3c4a63d1e46501edd8452
+pkgrel=1
pkgdesc="Atomic transactions for TinyDB"
arch=('any')
url="https://github.com/eugene-eeo/tinyrecord"
@@ -12,9 +13,8 @@ license=('MIT')
depends=('python-tinydb')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel' 'git')
checkdepends=('python-pytest')
-source=("$pkgname::git+$url#commit=6affc18?signed")
+source=("$pkgname::git+$url#commit=$_commit")
sha256sums=('SKIP')
-validpgpkeys=('BB354D48E3A3B416AC1242CB517D153BDE152D17')
build() {
cd "$pkgname"
@@ -30,7 +30,5 @@ package() {
cd "$pkgname"
PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
- local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
- install -d "$pkgdir/usr/share/licenses/$pkgname/"
- ln -s "$_site/$_pkg-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}