summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 350b4ad1ae07..b7f3c95041b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-todoist-api-python
pkgdesc = This is the official Python API client for the Todoist REST API.
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/Doist/todoist-api-python
arch = any
- license = BSD
+ license = MIT
makedepends = python-build
makedepends = python-installer
- makedepends = python-poetry
depends = python-requests
options = !emptydirs
- source = https://github.com/Doist/todoist-api-python/archive/v1.1.0.tar.gz
- sha256sums = 177abf9fbbb9f3f7d8cbcebc5ec8e2b37bd9c7e72b7682805d5647bf18b26eb8
+ source = https://files.pythonhosted.org/packages/source/t/todoist_api_python/todoist_api_python-1.1.0.tar.gz
+ sha256sums = cee8c8993e889635a9ad5947e40d0f5969f4fefc3787fd7be6f32e42561a2244
pkgname = python-todoist-api-python
diff --git a/.gitignore b/.gitignore
index b20752a93bec..a6b8c850ccb9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.gz
*.tar.xz
+*.tar.zst
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index cb33dd533528..0e3886708d6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=todoist-api-python
-pkgname=python-$_modulename
+pkgname=python-todoist-api-python
+_name=${pkgname#python-}
+__name=${_name//-/_}
pkgver=1.1.0
-pkgrel=1
+pkgrel=3
pkgdesc="This is the official Python API client for the Todoist REST API."
arch=(any)
-url="https://github.com/Doist/$_modulename"
-license=('BSD')
+url="https://github.com/Doist/$_name"
+license=('MIT')
groups=()
depends=(python-requests)
-makedepends=(python-build python-installer python-poetry)
+makedepends=(python-build python-installer)
provides=()
conflicts=()
replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('177abf9fbbb9f3f7d8cbcebc5ec8e2b37bd9c7e72b7682805d5647bf18b26eb8')
+source=("https://files.pythonhosted.org/packages/source/${__name::1}/$__name/$__name-$pkgver.tar.gz")
+sha256sums=('cee8c8993e889635a9ad5947e40d0f5969f4fefc3787fd7be6f32e42561a2244')
build() {
- cd "$srcdir/$_modulename-$pkgver"
- python -m build --wheel --no-isolation
+ cd "$srcdir/$__name-$pkgver"
+ python setup.py build
}
package() {
- cd "$srcdir/$_modulename-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "$srcdir/$__name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
}