summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0a663e874af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-torchdyn
+ pkgdesc = A PyTorch library entirely dedicated to neural differential equations, implicit models and related numerical methods
+ pkgver = 1.4.0.1
+ pkgrel = 1
+ url = https://github.com/DiffEqML/torchdyn
+ arch = any
+ license = Apache
+ checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry
+ depends = python-torchcde
+ depends = python-scikit-learn
+ depends = python-pytorch-lightning
+ depends = python-torchvision
+ depends = python-matplotlib
+ source = torchdyn-1.4.0.1.tar.gz::https://github.com/DiffEqML/torchdyn/archive/1.4.0.1.tar.gz
+ sha512sums = 119632764113c7c03300202c3b4bdde138c6b450f60aedf054ba57257e726f011d94638ebb800e4375c54ad1db5c94b14e9bd77d7add86c12a77e500c04196b6
+
+pkgname = python-torchdyn
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35d33fc72603
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=torchdyn
+pkgname=python-${_base}
+pkgdesc="A PyTorch library entirely dedicated to neural differential equations, implicit models and related numerical methods"
+pkgver=1.4.0.1
+pkgrel=1
+arch=(any)
+url="https://github.com/DiffEqML/${_base}"
+license=(Apache)
+depends=(python-torchcde python-scikit-learn python-pytorch-lightning python-torchvision python-matplotlib)
+makedepends=(python-build python-installer python-poetry)
+checkdepends=(python-pytest) # python-poethepoet
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('119632764113c7c03300202c3b4bdde138c6b450f60aedf054ba57257e726f011d94638ebb800e4375c54ad1db5c94b14e9bd77d7add86c12a77e500c04196b6')
+
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest test
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}