summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
-rw-r--r--fix-tests.patch29
3 files changed, 12 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d67438dbd35a..3539ce19f7bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-torchvision
pkgdesc = Datasets, transforms, and models specific to computer vision
- pkgver = 0.2.1
- pkgrel = 2
+ pkgver = 0.2.2
+ pkgrel = 1
url = https://pytorch.org
arch = any
license = BSD
@@ -11,11 +11,10 @@ pkgbase = python-torchvision
depends = python-numpy
depends = python-pillow
depends = python-pytorch
+ depends = python-scipy
depends = python-six
- source = torchvision-0.2.1.tar.gz::https://github.com/pytorch/vision/archive/v0.2.1.tar.gz
- source = fix-tests.patch::https://github.com/pytorch/vision/commit/4db0398a2b02aae790013efbc868f2d795eb2ef7.patch
- sha512sums = 224a07c24b2d990a2b396a7d499975347e45eccf501fd75bf528e4d5d92bd4c8f06382b8f3012263378a5e72271d3f9df4bc40248ec7fa218d2913355ed96740
- sha512sums = 624bbb9e96ccab3e7884a362015ee7ce159cb24e3fbb1d62575097658f494a7f7c21c511dc4946f808ba42143e9ba7cef9640e6aec234d36a3b48217a69d873c
+ source = torchvision-0.2.2.tar.gz::https://github.com/pytorch/vision/archive/v0.2.2.tar.gz
+ sha512sums = 36a6bbe133f70a319972bb1798a8f873d53440cc94fc7dc2a7cc2eff67d11bf4de90564c6f3c9f751a1b15fb1fefa2235c95aaf0040984f3c8f5bb8bcd069f57
pkgname = python-torchvision
diff --git a/PKGBUILD b/PKGBUILD
index 6e955ac9a794..7fc015e0f4fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,21 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+# Contributor: Chih-Hsuan Yen <yan12125@archlinux.org>
# Contributor: Jean Lucas <jean@4ray.co>
# Based on python-torchvision-git; original contributors:
# Contributor: Stephen Zhang <zsrkmyn at gmail dot com>
pkgname=python-torchvision
-pkgver=0.2.1
-pkgrel=2
+pkgver=0.2.2
+pkgrel=1
pkgdesc='Datasets, transforms, and models specific to computer vision'
arch=(any)
url=https://pytorch.org
license=(BSD)
-depends=(python-numpy python-pillow python-pytorch python-six)
+depends=(python-numpy python-pillow python-pytorch python-scipy python-six)
makedepends=(python-setuptools)
checkdepends=(python-pytest python-scipy)
-source=("torchvision-$pkgver.tar.gz"::"https://github.com/pytorch/vision/archive/v$pkgver.tar.gz"
- fix-tests.patch::https://github.com/pytorch/vision/commit/4db0398a2b02aae790013efbc868f2d795eb2ef7.patch)
-sha512sums=('224a07c24b2d990a2b396a7d499975347e45eccf501fd75bf528e4d5d92bd4c8f06382b8f3012263378a5e72271d3f9df4bc40248ec7fa218d2913355ed96740'
- '624bbb9e96ccab3e7884a362015ee7ce159cb24e3fbb1d62575097658f494a7f7c21c511dc4946f808ba42143e9ba7cef9640e6aec234d36a3b48217a69d873c')
-
-prepare() {
- cd vision-$pkgver
- patch -Np1 -i ../fix-tests.patch
-}
+source=("torchvision-$pkgver.tar.gz"::"https://github.com/pytorch/vision/archive/v$pkgver.tar.gz")
+sha512sums=('36a6bbe133f70a319972bb1798a8f873d53440cc94fc7dc2a7cc2eff67d11bf4de90564c6f3c9f751a1b15fb1fefa2235c95aaf0040984f3c8f5bb8bcd069f57')
build() {
cd vision-$pkgver
diff --git a/fix-tests.patch b/fix-tests.patch
deleted file mode 100644
index 8610e2fa896e..000000000000
--- a/fix-tests.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 4db0398a2b02aae790013efbc868f2d795eb2ef7 Mon Sep 17 00:00:00 2001
-From: vfdev <vfdev.5@gmail.com>
-Date: Fri, 4 May 2018 22:41:13 +0200
-Subject: [PATCH] Update test_utils.py (#486)
-
-Remove test with variables
----
- test/test_utils.py | 8 --------
- 1 file changed, 8 deletions(-)
-
-diff --git a/test/test_utils.py b/test/test_utils.py
-index df6ae972..2f8392e0 100644
---- a/test/test_utils.py
-+++ b/test/test_utils.py
-@@ -18,14 +18,6 @@ def test_make_grid_not_inplace(self):
- utils.make_grid(t, normalize=True, scale_each=True)
- assert torch.equal(t, t_clone), 'make_grid modified tensor in-place'
-
-- def test_make_grid_raises_with_variable(self):
-- t = torch.autograd.Variable(torch.rand(3, 10, 10))
-- with self.assertRaises(TypeError):
-- utils.make_grid(t)
--
-- with self.assertRaises(TypeError):
-- utils.make_grid([t, t, t, t])
--
-
- if __name__ == '__main__':
- unittest.main()