summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8df3bacc7c93..044f43c5e6b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-trezor
pkgdesc = Python 3 library for communicating with the TREZOR Bitcoin hardware wallet
- pkgver = 0.11.6
+ pkgver = 0.13.8
pkgrel = 1
url = https://github.com/trezor/trezor-firmware/tree/master/python
arch = any
@@ -9,21 +9,22 @@ pkgbase = python-trezor
depends = protobuf
depends = python
depends = python-ecdsa
- depends = python-hidapi
depends = python-mnemonic
- depends = python-click
- depends = python-pyblake2
- depends = python-protobuf
depends = python-requests
- depends = python-construct
+ depends = python-click
depends = python-libusb1
+ depends = python-construct
depends = python-typing_extensions
+ depends = python-simple-rlp
+ depends = python-construct-classes
+ depends = python-protobuf
+ depends = python-attrs
+ optdepends = python-hidapi: Firmware-less Trezor One setup
provides = python-trezor
provides = trezorctl
conflicts = trezorctl
options = !emptydirs
- source = https://files.pythonhosted.org/packages/84/95/61ae38cd07211ba4a7f7610a64f4255d2804da311e66638bdb9c0aebc9df/trezor-0.11.6.tar.gz
- sha256sums = 101e0400f5b148b28056a0a5a21f4b4d4f6cd88dd780601397af81280292e3c4
+ source = https://files.pythonhosted.org/packages/source/t/trezor/trezor-0.13.8.tar.gz
+ sha256sums = 634d4eddf35603257c321618d8548c6a35b27384657b65e3b0bdbad635a57cff
pkgname = python-trezor
-
diff --git a/PKGBUILD b/PKGBUILD
index 2733f52ae826..787ef2765672 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,45 @@
-# Maintainer: yate <mwyeatts at gmail dot com>
-# Maintainer: Xaiuweb <xaiuweb@protonmail.ch>
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Contributor: yate <mwyeatts at gmail dot com>
+# Contributor: Xaiuweb <xaiuweb@protonmail.ch>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=python-trezor
-pkgver=0.11.6
+_pkgname=${pkgname#python-}
+pkgver=0.13.8
pkgrel=1
pkgdesc='Python 3 library for communicating with the TREZOR Bitcoin hardware wallet'
arch=('any')
+makedepends=('python-setuptools')
depends=('protobuf'
'python'
'python-ecdsa'
- 'python-hidapi'
'python-mnemonic'
- 'python-click'
- 'python-pyblake2'
- 'python-protobuf'
'python-requests'
- 'python-construct'
+ 'python-click'
'python-libusb1'
- 'python-typing_extensions')
-makedepends=('python-setuptools')
+ 'python-construct'
+ 'python-typing_extensions'
+ 'python-simple-rlp'
+ 'python-construct-classes'
+ 'python-protobuf'
+ 'python-attrs')
+optdepends=('python-hidapi: Firmware-less Trezor One setup')
url='https://github.com/trezor/trezor-firmware/tree/master/python'
license=('LGPL3')
options=(!emptydirs)
-source=('https://files.pythonhosted.org/packages/84/95/61ae38cd07211ba4a7f7610a64f4255d2804da311e66638bdb9c0aebc9df/trezor-0.11.6.tar.gz')
-sha256sums=('101e0400f5b148b28056a0a5a21f4b4d4f6cd88dd780601397af81280292e3c4')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('634d4eddf35603257c321618d8548c6a35b27384657b65e3b0bdbad635a57cff')
provides=('python-trezor' 'trezorctl')
conflicts=('trezorctl')
build() {
- cd "$srcdir/${pkgname#python-}-$pkgver"
+ cd "${pkgname#python-}-$pkgver"
- msg2 'Building...'
python setup.py build
}
package() {
- cd "$srcdir/${pkgname#python-}-$pkgver"
+ cd "${pkgname#python-}-$pkgver"
- msg2 'Installing...'
python setup.py install --root="$pkgdir" --optimize=1
}