summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD22
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c8530ae78ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-twilio
+ pkgdesc = A module for using the Twilio REST API and generating valid TwiML.
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://github.com/twilio/twilio-python
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-httplib2>=0.7
+ depends = python-socks
+ depends = python-pytz
+ depends = python-six
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/t/twilio/twilio-4.0.0.tar.gz
+ source = LICENSE
+ sha256sums = b95a96ff916922a5ae13dfbcdb1968db695ebc66f385e255db6ed3736a16be64
+ sha256sums = 17db7e6dddc3a621518f20dd4b35dac73f25160680d2a4858654eca1019bdea6
+
+pkgname = python-twilio
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a2cd4a36366d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2012 Twilio, Inc.
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation
+files (the "Software"), to deal in the Software without
+restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e94f2e25488
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=python-twilio
+pkgver=3.6.4
+pkgrel=3
+pkgdesc="A module for using the Twilio REST API and generating valid TwiML."
+arch=('any')
+url="https://github.com/twilio/twilio-python"
+license=('MIT')
+depends=('python' 'python-httplib2' 'python-socksipy-branch')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/t/twilio/twilio-${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('8a1e2059758204bacc206ce6bd63d7a0b0393e31e21a26ca5031bb1c80c0f4a5'
+ '17db7e6dddc3a621518f20dd4b35dac73f25160680d2a4858654eca1019bdea6')
+
+package() {
+ cd "$srcdir/twilio-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: