summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baef1741495f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-vatnumber
+ pkgdesc = Python module to validate VAT numbers
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/vatnumber
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-suds: SOAP client for European Union's Vat information exchange service
+ conflicts = python-vatnumber
+ source = https://pypi.python.org/packages/d7/7c/869b59cd9cb6ed1057372cb704a3b86688ae8c12cfc7fcaedbc1424f5e7f/vatnumber-1.2.tar.gz
+ md5sums = 3b1541be3834a865f6f7bcce809ffb25
+
+pkgname = python-vatnumber
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fb56c019433
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Contributor: M0Rf30
+# Contributor: Gour <gour@gour-nitai.com>
+
+pkgname=python-vatnumber
+_pkgname=vatnumber
+pkgver=1.2
+pkgrel=1
+pkgdesc="Python module to validate VAT numbers"
+arch=('any')
+url="https://pypi.python.org/pypi/vatnumber"
+conflicts=('python-vatnumber')
+license=('GPL3')
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=("python-suds: SOAP client for European Union's Vat information exchange service")
+
+source=("https://pypi.python.org/packages/d7/7c/869b59cd9cb6ed1057372cb704a3b86688ae8c12cfc7fcaedbc1424f5e7f/$_pkgname-$pkgver.tar.gz")
+md5sums=('3b1541be3834a865f6f7bcce809ffb25')
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py install --root=$pkgdir
+}