summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1bfc21d6a76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-vcard
+ pkgdesc = vCard validator
+ pkgver = 0.10.2
+ pkgrel = 1
+ url = https://github.com/l0b0/vcard
+ arch = any
+ license = GPL3
+ makedepends = python
+ depends = python
+ depends = python-isodate
+ provides = python-vcard
+ conflicts = python-vcard-git
+ source = https://files.pythonhosted.org/packages/source/v/vcard/vcard-0.10.2.tar.gz
+ sha512sums = 7fdcdccbe6c27f059c79169b652a84265741d96b1f242929b2406462f0bbd8ab3d071653fcb0ca4b29ea5a8d2763a8c4b89f23b22fbcb0537e5281f4621f380e
+
+pkgname = python-vcard
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..80b83e377611
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+.idea/
+pkg/
+*.pkg.tar.xz
+src/
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43378faadeae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Victor Engmark <victor.engmark@gmail.com>
+pkgname=python-vcard
+_name="${pkgname#*-}"
+pkgver=0.10.2
+pkgrel=1
+pkgdesc="vCard validator"
+arch=('any')
+url='https://github.com/l0b0/vcard'
+license=('GPL3')
+depends=('python' 'python-isodate')
+makedepends=('python')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha512sums=('7fdcdccbe6c27f059c79169b652a84265741d96b1f242929b2406462f0bbd8ab3d071653fcb0ca4b29ea5a8d2763a8c4b89f23b22fbcb0537e5281f4621f380e')
+
+package() {
+ cd "$srcdir/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}