summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6352affae57f..28707d557e6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,12 @@
pkgbase = python-vcrpy-git
pkgdesc = VCR.py simplifies and speeds up tests that make HTTP requests.
- pkgver = 2.7.r835.0cf11d4
+ pkgver = 4.1.1.r1006.c79a06f
pkgrel = 1
url = https://github.com/kevin1024/vcrpy
arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
depends = python
provides = python-vcrpy
conflicts = python-vcrpy
@@ -11,4 +14,3 @@ pkgbase = python-vcrpy-git
md5sums = SKIP
pkgname = python-vcrpy-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2ee7f3492085..201a87641f49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: DanManN <dnahimov@gmail.com>
+# Maintainer: DanielNak <daniel@tee.cat>
# Python package author: Kevin McCarthy <me@kevinmccarthy.org>
_pkgname=vcrpy
_author=kevin1024
pkgname=python-$_pkgname-git
-pkgver=2.7.r835.0cf11d4
+pkgver=4.1.1.r1006.c79a06f
pkgrel=1
pkgdesc="VCR.py simplifies and speeds up tests that make HTTP requests."
arch=('any')
url="https://github.com/$_author/$_pkgname"
-license=('')
+license=('MIT')
depends=('python')
-makedepends=('')
+makedepends=('git' 'python-setuptools')
provides=("python-$_pkgname")
conflicts=("python-$_pkgname")
source=("git+https://github.com/$_author/$_pkgname.git")
@@ -19,12 +19,12 @@ md5sums=('SKIP')
prepare() {
cd "$_pkgname"
- git checkout $(curl https://api.github.com/repos/$_author/$_pkgname/releases/latest | grep tag_name| cut -d '"' -f4)
+ git checkout $(curl https://api.github.com/repos/$_author/$_pkgname/releases | grep tag_name | cut -d '"' -f4 | head -n 1)
}
pkgver() {
cd "$_pkgname"
- printf "%s.r%s.%s" "$(cat setup.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.r%s.%s" "$(cat vcr/__init__.py | grep -i version | grep -v '#' | cut -d '"' -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {