summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD57
4 files changed, 37 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 254c17158c79..8fde367a135f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = python-vt-py
pkgdesc = Official Python client library for VirusTotal's REST API
- pkgver = 0.15.0
+ pkgver = 0.18.2
pkgrel = 1
url = https://github.com/virustotal/vt-py
arch = any
- license = Apache
- checkdepends = python-pytest
+ license = Apache-2.0
checkdepends = python-pytest-asyncio
checkdepends = python-pytest-httpserver
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
- makedepends = python-sphinx
makedepends = python-wheel
+ makedepends = python-sphinx
depends = python-aiohttp
provides = python-virustotal
replaces = python-virustotal-api
- source = python-vt-py-0.15.0.tar.gz::https://github.com/virustotal/vt-py/archive/0.15.0.tar.gz
- sha256sums = 0a84bf5b62b80c140c2f26e9cdafa1bbe0bde73decff610f4d908c1ba1e79975
+ source = python-vt-py-0.18.2.tar.gz::https://github.com/virustotal/vt-py/archive/0.18.2.tar.gz
+ sha512sums = ed908921426f5a9551a54281c55d66fbed4670098afaeaaf5585f2005fd4fa98e39d6cfcfda62196609f3c199d22b782c8f6709285a2622841919c51f114cd74
pkgname = python-vt-py
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..bb3017045e9f
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[python-vt-py]
+source = "github"
+github = "virustotal/vt-py"
+use_latest_release = "true"
diff --git a/PKGBUILD b/PKGBUILD
index c751e48e576b..9aab0bdb09e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,41 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-
-pkgname=python-vt-py
-_pkg="${pkgname#python-}"
-pkgver=0.15.0
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+_base=vt-py
+pkgname=python-${_base}
+pkgver=0.18.2
pkgrel=1
pkgdesc="Official Python client library for VirusTotal's REST API"
-arch=('any')
-url="https://github.com/virustotal/vt-py"
-license=('Apache')
-depends=('python-aiohttp')
-makedepends=(
- 'python-build'
- 'python-installer'
- 'python-setuptools'
- 'python-sphinx'
- 'python-wheel')
-checkdepends=('python-pytest' 'python-pytest-asyncio' 'python-pytest-httpserver')
-provides=('python-virustotal')
-replaces=('python-virustotal-api')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('0a84bf5b62b80c140c2f26e9cdafa1bbe0bde73decff610f4d908c1ba1e79975')
+arch=(any)
+url="https://github.com/virustotal/${_base}"
+license=(Apache-2.0)
+depends=(python-aiohttp)
+makedepends=(python-build python-installer python-setuptools python-wheel python-sphinx)
+checkdepends=(python-pytest-asyncio python-pytest-httpserver)
+provides=(python-virustotal)
+replaces=(python-virustotal-api)
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('ed908921426f5a9551a54281c55d66fbed4670098afaeaaf5585f2005fd4fa98e39d6cfcfda62196609f3c199d22b782c8f6709285a2622841919c51f114cd74')
prepare() {
- cd "$_pkg-$pkgver"
- sed -i '/setup_requires/d' setup.py
+ sed -i '/setup_requires/d' ${_base}-${pkgver}/setup.py
}
build() {
- cd "$_pkg-$pkgver"
- python -m build --wheel --no-isolation
- PYTHONPATH="$PWD" sphinx-build -b man docs/source _build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+ PYTHONPATH="${PWD}" sphinx-build -b man docs/source _build
}
check() {
- cd "$_pkg-$pkgver"
- pytest -x --disable-warnings
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
}
package() {
- cd "$_pkg-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 "_build/$_pkg.1" -t "$pkgdir/usr/share/man/man1/"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 "_build/${_base}.1" -t "$pkgdir/usr/share/man/man1/"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}