summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3438b4f83fb2..c8c1fe05596f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,19 +2,18 @@ pkgbase = python-wasmtime
pkgdesc = Python 3 extension for interface with Wasmtime/Cranelift.
pkgver = 0.16.0
pkgrel = 1
- url = https://github.com/bytecodealliance/wasmtime
+ url = https://github.com/bytecodealliance/wasmtime-py
arch = i686
arch = x86_64
arch = armv7h
arch = aarch64
license = APACHE2
- makedepends = rustup
depends = python
depends = python-setuptools
depends = python-wheel
- depends = python-setuptools-rust
+ depends = wasmtime
options = !emptydirs
- source = python-wasmtime-0.16.0::git+https://github.com/bytecodealliance/wasmtime.git#tag=v0.16.0
+ source = python-wasmtime-0.16.0::git+https://github.com/bytecodealliance/wasmtime-py.git#tag=0.16.0
sha384sums = SKIP
pkgname = python-wasmtime
diff --git a/PKGBUILD b/PKGBUILD
index 2bdf63625ff3..1fc6b2899de5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,11 @@ pkgver=0.16.0
pkgrel=1
pkgdesc="Python 3 extension for interface with Wasmtime/Cranelift."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-url="https://github.com/bytecodealliance/wasmtime"
+url="https://github.com/bytecodealliance/wasmtime-py"
license=('APACHE2')
-depends=('python' 'python-setuptools' 'python-wheel' 'python-setuptools-rust')
-makedepends=('rustup')
+depends=('python' 'python-setuptools' 'python-wheel' 'wasmtime')
options=(!emptydirs)
-source=("${pkgname}-${pkgver}::git+https://github.com/bytecodealliance/wasmtime.git#tag=v${pkgver}")
+source=("${pkgname}-${pkgver}::git+https://github.com/bytecodealliance/wasmtime-py.git#tag=${pkgver}")
sha384sums=('SKIP')
prepare() {
@@ -19,6 +18,7 @@ prepare() {
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/crates/misc/py"
- rustup run nightly python setup.py install --root="$pkgdir/" --optimize=1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ ln -sf "/usr/lib/libwasmtime.so" "${pkgdir}/""$(python -c "import setuptools as _; print(_.__path__[0][:-10])")""wasmtime/wasmtime.pyd"
}