summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f972c56fecb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-wifi
+ pkgdesc = A Python module that provides read and write access to a wireless network card's capabilities using the Linux Wireless Extensions.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/python-wifi
+ arch = any
+ license = LGPL
+ license = GPL
+ makedepends = python-distribute
+ depends = python
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/python-wifi/python-wifi-0.6.0.tar.bz2
+ md5sums = f9d520a8c17b0dfffce95a8a7efba7dd
+
+pkgname = python-wifi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f30e9c6b2c7e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+python-wifi-*.pkg.tar.xz
+python-wifi-*.src.tar.gz
+python-wifi-*.tar.bz2
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f38a4e2c9638
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Lev Lybin <lev.lybin@gmail.com>
+# Contributor: Lev Lybin <lev.lybin@gmail.com>
+
+_pkgname=python-wifi
+pkgname=python-wifi
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="A Python module that provides read and write access to a wireless network card's capabilities using the Linux Wireless Extensions."
+arch=('any')
+url="https://pypi.python.org/pypi/python-wifi"
+license=('LGPL' 'GPL')
+depends=('python')
+makedepends=('python-distribute')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.bz2")
+md5sums=('f9d520a8c17b0dfffce95a8a7efba7dd')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # fix unicode error
+ sed -i '/author = \"R/c\ author = \"Roman Joost\",' "${srcdir}/${_pkgname}-${pkgver}/setup.py"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+} \ No newline at end of file