summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26e40721e5b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Dec 19 16:12:54 UTC 2016
+pkgbase = python-wifiwrapper
+ pkgdesc = Command line tool and library wrappers around iwlist and /etc/network/interfaces
+ pkgver = 0.3.8
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/wifi
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = https://pypi.python.org/packages/fe/a9/d026afe8a400dd40122385cd690e4fff4d574ed16f5c3a0f5e3921bfd383/wifi-0.3.8.tar.gz
+ sha256sums = a9880b2e91ea8420154c6826c8112a2f541bbae5641d59c5cb031d27138d7f26
+
+pkgname = python-wifiwrapper
+ pkgdesc = Command line tool and library wrappers around iwlist and /etc/network/interfaces. (python3 version)
+ depends = python
+
+pkgname = python2-wifiwrapper
+ pkgdesc = Command line tool and library wrappers around iwlist and /etc/network/interfaces. (python2 version)
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18e86d454c9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgbase=python-wifiwrapper
+pkgname=('python-wifiwrapper' 'python2-wifiwrapper')
+pkgname=python-wifiwrapper
+pkgver=0.3.8
+pkgrel=1
+pkgdesc="Command line tool and library wrappers around iwlist and /etc/network/interfaces"
+arch=(any)
+url="https://pypi.python.org/pypi/wifi"
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/fe/a9/d026afe8a400dd40122385cd690e4fff4d574ed16f5c3a0f5e3921bfd383/wifi-0.3.8.tar.gz")
+sha256sums=('a9880b2e91ea8420154c6826c8112a2f541bbae5641d59c5cb031d27138d7f26')
+
+package_python2-wifiwrapper() {
+ depends=('python2')
+ pkgdesc="Command line tool and library wrappers around iwlist and /etc/network/interfaces. (python2 version)"
+
+ cd "${srcdir}/wifi-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -v -m755 -d "${pkgdir}/usr/share/doc/python2-wifiwrapper"
+ install -v -m644 README.rst "${pkgdir}/usr/share/doc/python2-wifiwrapper/"
+}
+
+package_python-wifiwrapper() {
+ depends=('python')
+ pkgdesc="Command line tool and library wrappers around iwlist and /etc/network/interfaces. (python3 version)"
+
+ cd "${srcdir}/wifi-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -v -m755 -d "${pkgdir}/usr/share/doc/python-wifiwrapper"
+ install -v -m644 README.rst "${pkgdir}/usr/share/doc/python-wifiwrapper/"
+}