summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 226e1838b665..6e62525d378a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,15 @@
pkgbase = python-wordcloud
pkgdesc = A little word cloud generator in Python
pkgver = 1.9.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/amueller/word_cloud
arch = any
license = Apache
makedepends = python-setuptools
+ makedepends = python-setuptools-scm
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = cython
depends = python
depends = python-matplotlib
diff --git a/PKGBUILD b/PKGBUILD
index e842e4e13d2f..71cf5925f025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,24 @@
_pkgname=wordcloud
pkgname=python-wordcloud
pkgver=1.9.3
-pkgrel=1
+pkgrel=2
pkgdesc="A little word cloud generator in Python"
arch=('any')
url="https://github.com/amueller/word_cloud"
license=('Apache')
-makedepends=('python-setuptools' 'cython')
+makedepends=('python-setuptools' 'python-setuptools-scm' 'python-build' 'python-installer' 'python-wheel' 'cython')
depends=('python' 'python-matplotlib' 'python-pillow' 'python-numpy')
source=("https://files.pythonhosted.org/packages/7c/60/5f927145b65de0f299079db846c89fa031d56e4df9764607add12a03714e/$_pkgname-$pkgver.tar.gz")
sha256sums=('a9aa738d63ed674a40f0cc31adb83f4ca5fc195f03a6aff6e010d1f5807d1c58')
+build() {
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: