summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68a1f7da8cb7..a8b6277961c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-wstool
- pkgdesc = workspace multi-SCM commands
- pkgver = 0.1.17
- pkgrel = 2
- url = http://wiki.ros.org/wstool
+ pkgdesc = Command-line tool for maintaining a workspace of projects from multiple version-control systems
+ pkgver = 0.1.18
+ pkgrel = 1
+ url = https://github.com/vcstools/wstool
arch = any
license = BSD
makedepends = python-setuptools
@@ -10,8 +10,8 @@ pkgbase = python-wstool
depends = python-vcstools
depends = python-yaml
conflicts = python2-wstool
- source = https://files.pythonhosted.org/packages/source/w/wstool/wstool-0.1.17.tar.gz
- sha256sums = c79b4f110ef17004c24972d742d2c5f606b0f6b424295e7ed029a48e857de237
+ source = https://github.com/vcstools/wstool/archive/0.1.18.tar.gz
+ sha256sums = f04621acda755a45896db2d3a84131f96cf69905515997637b4568f3fad5c46e
pkgname = python-wstool
diff --git a/PKGBUILD b/PKGBUILD
index b8437dd9e233..d9b9465a7df7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python-wstool'
pkgname=('python-wstool')
-_module='wstool'
-pkgver='0.1.17'
-pkgrel=2
-pkgdesc="workspace multi-SCM commands"
-url="http://wiki.ros.org/wstool"
+pkgver='0.1.18'
+pkgrel=1
+pkgdesc='Command-line tool for maintaining a workspace of projects from multiple version-control systems'
+arch=('any')
+url='https://github.com/vcstools/wstool'
+license=('BSD')
depends=('python' 'python-vcstools' 'python-yaml')
-conflicts=('python2-wstool')
makedepends=('python-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('c79b4f110ef17004c24972d742d2c5f606b0f6b424295e7ed029a48e857de237')
+
+conflicts=('python2-wstool')
+source=("https://github.com/vcstools/wstool/archive/${pkgver}.tar.gz")
+sha256sums=('f04621acda755a45896db2d3a84131f96cf69905515997637b4568f3fad5c46e')
+
+_module='wstool'
build() {
cd "${srcdir}/${_module}-${pkgver}"