summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b76d752e7b70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-x11_hash
+ pkgdesc = Binding for X11 proof of work hashing (Py3)
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/mazaclub/x11_hash
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python3
+ source = https://github.com/mazaclub/x11_hash/archive/1.4.tar.gz
+ md5sums = aeb83b7e868f504890a6a8d12c9ef2a0
+
+pkgname = python-x11_hash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6d6c6b049ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Daniel Case <daniel@dashlabs.org>
+# Contributor: Andy Kluger <AndyKluger@gmail.com>
+
+_pkgname=x11_hash
+pkgname=python-${_pkgname}
+pkgver=1.4
+pkgrel=1
+pkgdesc="Binding for Dash's X11 proof of work hashing."
+arch=(any)
+url="https://github.com/mazaclub/x11_hash"
+license=('MIT')
+depends=('python3')
+makedepends=('python-setuptools')
+source=("https://github.com/mazaclub/x11_hash/archive/${pkgver}.tar.gz")
+
+package_python-x11_hash(){
+ cd ${_pkgname}-${pkgver}
+ python3 setup.py install --root="$pkgdir"
+}
+
+md5sums=('aeb83b7e868f504890a6a8d12c9ef2a0')