summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD48
3 files changed, 49 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f780c80fd1d..b6ca75ffffda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-xarray
pkgdesc = N-D labeled arrays and datasets in Python
- pkgver = 0.12.0
+ pkgver = 0.15.0
pkgrel = 1
url = http://xarray.pydata.org
arch = any
@@ -9,16 +9,22 @@ pkgbase = python-xarray
makedepends = python-setuptools
depends = python-numpy
depends = python-pandas
- optdepends = python-netcdf4: NetCDF4 support
- optdepends = python-bottleneck: Faster NaN operations
- optdepends = python-scipy: OPeNDAP support
- optdepends = python-matplotlib: Plotting support
+ optdepends = python-netcdf4: netCDF4 support
+ optdepends = python-scipy: Interpolation and fallback netCDF3 support
+ optdepends = python-h5netcdf: Alternative for netCDF4 support
+ optdepends = python-zarr: Chunked, compressed N-dimensional arrays
+ optdepends = python-cftime: Datetime support for non-standard calendars and distant dates
+ optdepends = python-rasterio: Read GeoTiffs and other gridded raster datasets
+ optdepends = python-bottleneck: Faster NaN-skipping and rolling window aggregations
optdepends = python-dask: Enable out-of-core parallel computation
+ optdepends = python-matplotlib: Plotting support
+ optdepends = python-cartopy: Plotting of cartographic data
+ optdepends = python-seaborn: Improved color palettes for plots
+ optdepends = python-sparse: Sparse multi-dimensional arrays
replaces = python-xray
- source = https://files.pythonhosted.org/packages/source/x/xarray/xarray-0.12.0.tar.gz
- md5sums = 55bc20b431220203a3502607d13f4e0c
- sha1sums = f3e06a2f52d86847a3596468a76e5a2d4c04e691
- sha256sums = 856fd062c55208a248ac3784cac8d3524b355585387043efc92a4188eede57f3
+ source = https://files.pythonhosted.org/packages/source/x/xarray/xarray-0.15.0.tar.gz
+ md5sums = 75199f462de36f36b89b3f374ad7ec98
+ sha256sums = c72d160c970725201f769e80fb91cbad68d6ebf21d68fcc371385a6c950459c3
pkgname = python-xarray
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3def1cb7adc6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.log
+*.tar.xz
+*.tar.zst
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 63b72a5da24a..a657e1995ccb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Rich Li <rich@dranek.com>
-pkgname='python-xarray'
-_name=${pkgname#python-}
-pkgver=0.12.0
+# Maintainer: Blair Bonnett <blair.bonnett@gmail.com>
+# Contributor: Rich Li <rich@dranek.com>
+
+pkgname=python-xarray
+pkgver=0.15.0
pkgrel=1
pkgdesc="N-D labeled arrays and datasets in Python"
url="http://xarray.pydata.org"
@@ -9,30 +10,37 @@ arch=('any')
license=('Apache')
makedepends=('python-setuptools')
depends=('python-numpy' 'python-pandas')
-optdepends=('python-netcdf4: NetCDF4 support'
- 'python-bottleneck: Faster NaN operations'
- # 'python-pynio: GRIB and other file format support' # (no Python 3 support yet)
- 'python-scipy: OPeNDAP support'
- 'python-matplotlib: Plotting support'
- 'python-dask: Enable out-of-core parallel computation')
+optdepends=(
+ 'python-netcdf4: netCDF4 support'
+ 'python-scipy: Interpolation and fallback netCDF3 support'
+ 'python-h5netcdf: Alternative for netCDF4 support'
+ 'python-zarr: Chunked, compressed N-dimensional arrays'
+ 'python-cftime: Datetime support for non-standard calendars and distant dates'
+ 'python-rasterio: Read GeoTiffs and other gridded raster datasets'
+ 'python-bottleneck: Faster NaN-skipping and rolling window aggregations'
+ 'python-dask: Enable out-of-core parallel computation'
+ 'python-matplotlib: Plotting support'
+ 'python-cartopy: Plotting of cartographic data'
+ 'python-seaborn: Improved color palettes for plots'
+ 'python-sparse: Sparse multi-dimensional arrays'
+
+)
checkdepends=('python-pytest')
replaces=('python-xray')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('55bc20b431220203a3502607d13f4e0c')
-sha1sums=('f3e06a2f52d86847a3596468a76e5a2d4c04e691')
-sha256sums=('856fd062c55208a248ac3784cac8d3524b355585387043efc92a4188eede57f3')
+source=("https://files.pythonhosted.org/packages/source/x/xarray/xarray-${pkgver}.tar.gz")
+md5sums=('75199f462de36f36b89b3f374ad7ec98')
+sha256sums=('c72d160c970725201f769e80fb91cbad68d6ebf21d68fcc371385a6c950459c3')
build() {
cd "$srcdir/xarray-$pkgver"
python setup.py build
}
-# NB: the default test suite seems to require dask being installed
-# check() {
-# cd "$srcdir/xarray-$pkgver"
-# pytest --disable-warnings xarray
-# }
-
+check() {
+ cd "$srcdir/xarray-$pkgver"
+ pytest
+}
+
package() {
cd "$srcdir/xarray-$pkgver"
python setup.py install --skip-build --prefix=/usr --root="$pkgdir/" --optimize=1