summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 739a5e4dc38e..09c83270f190 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = python-yalafi
pkgdesc = Yet another LaTeX filter
- pkgver = 1.4.0
- pkgrel = 4
+ pkgver = 1.5.0
+ pkgrel = 1
url = https://github.com/torik42/YaLafi
arch = any
license = GPL3
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-wheel
depends = python
depends = languagetool
- source = https://github.com/torik42/YaLafi/archive/1.4.0.zip
+ source = https://github.com/torik42/YaLafi/archive/1.5.0.zip
source = ltdirectory.patch
- sha256sums = 0062175c40659eb16beff26cb934f073c87f6e6e5f56657b713eb401ec6973cc
+ sha256sums = 54b2a347875ded37edc1db04f7d836704514f216bbb6a9d62e732a9d525e276d
sha256sums = ff59913ed6c4cc63dcf47f9604d5a096bd30e152f14e36ec53fa1e37793e5c10
pkgname = python-yalafi
diff --git a/PKGBUILD b/PKGBUILD
index 4801b4f0c2b2..ddf37ec10213 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,32 @@
# Contributor: Joakim Repomaa <aur@j.repomaa.com>
pkgname=python-yalafi
-pkgver=1.4.0
-pkgrel=4
+pkgver=1.5.0
+pkgrel=1
pkgdesc="Yet another LaTeX filter"
url="https://github.com/torik42/YaLafi"
depends=('python' 'languagetool')
-makedepends=('python-build' 'python-installer' 'python-wheel')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
license=('GPL3')
arch=('any')
source=(
- "https://github.com/torik42/YaLafi/archive/$pkgver.zip"
- "ltdirectory.patch"
+ "https://github.com/torik42/YaLafi/archive/$pkgver.zip"
+ "ltdirectory.patch"
)
-sha256sums=('0062175c40659eb16beff26cb934f073c87f6e6e5f56657b713eb401ec6973cc'
+sha256sums=('54b2a347875ded37edc1db04f7d836704514f216bbb6a9d62e732a9d525e276d'
'ff59913ed6c4cc63dcf47f9604d5a096bd30e152f14e36ec53fa1e37793e5c10')
prepare() {
- cd YaLafi-$pkgver
- patch -p1 < "$srcdir/ltdirectory.patch"
+ cd YaLafi-$pkgver
+ patch -p1 <"$srcdir/ltdirectory.patch"
}
build() {
- cd YaLafi-$pkgver
- python -m build --wheel --no-isolation
+ cd YaLafi-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd YaLafi-$pkgver
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd YaLafi-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
}