summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f39d0581660
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-yoyo-migrations
+ pkgdesc = Database migrations with SQL
+ pkgver = 6.1.0
+ pkgrel = 1
+ url = https://ollycope.com/software/yoyo/latest/
+ arch = any
+ license = Apache
+ makedepends = python-pip
+ depends = python
+ depends = python-iniherit
+ depends = python-text-unidecode
+ source = https://files.pythonhosted.org/packages/a3/fc/5c80eb3dd9689c704db38c9a412b33cbc07f4838d11f5a2cf2bbf40d09f9/yoyo-migrations-6.1.0.tar.gz
+ sha256sums = 4538dbdfe4784c30bade14275558247ec8ce8111b4948dc38f51d4172f9d513c
+
+pkgname = python-yoyo-migrations
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98fb7f7be9c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: lll2yu <lll2yu@protonmail.com>
+
+pkgname=python-yoyo-migrations
+pkgver=6.1.0
+pkgrel=1
+pkgdesc='Database migrations with SQL'
+arch=(any)
+url=https://ollycope.com/software/yoyo/latest/
+license=(Apache)
+depends=('python' 'python-iniherit' 'python-text-unidecode')
+makedepends=('python-pip')
+source=(https://files.pythonhosted.org/packages/a3/fc/5c80eb3dd9689c704db38c9a412b33cbc07f4838d11f5a2cf2bbf40d09f9/yoyo-migrations-$pkgver.tar.gz)
+sha256sums=('4538dbdfe4784c30bade14275558247ec8ce8111b4948dc38f51d4172f9d513c')
+
+package() {
+ cd yoyo-migrations-$pkgver
+ python setup.py install -O1 --root="$pkgdir"
+}