summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD32
2 files changed, 24 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad0b2cc3d0d7..06663364c9d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Feb 18 15:41:09 UTC 2019
+# Sun Mar 24 15:56:07 UTC 2019
pkgbase = python2-androguard
pkgdesc = Python framework for Android application analysis.
pkgver = 3.3.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/androguard/androguard/
arch = any
license = Apache
@@ -14,26 +14,27 @@ pkgbase = python2-androguard
pkgname = python2-androguard
depends = python2
depends = python2-setuptools
- optdepends = ipython2: interactive analysis support
- optdepends = python2-pygments: color support
- optdepends = python2-magic: file identification support
- optdepends = sparsehash: elsim support
- optdepends = muparser: elsim support
- optdepends = snappy: elsim support
- optdepends = bzip2: elsim support
- optdepends = zlib: elsim support
- optdepends = python2-pyside: GUI
+ depends = ipython2<6
+ depends = python2-future
+ depends = python2-networkx
+ depends = python2-pygments
+ depends = python2-colorama
+ depends = python2-matplotlib
+ depends = python2-asn1crypto
+ depends = python2-click
+ depends = python2-pydot
pkgname = python-androguard
depends = python
depends = python-setuptools
- optdepends = ipython: interactive analysis support
- optdepends = python-pygments: color support
- optdepends = python-magic: file identification support
- optdepends = sparsehash: elsim support
- optdepends = muparser: elsim support
- optdepends = snappy: elsim support
- optdepends = bzip2: elsim support
- optdepends = zlib: elsim support
- optdepends = python-pyside: GUI
+ depends = ipython
+ depends = python-future
+ depends = python-networkx
+ depends = python-pygments
+ depends = python-lxml
+ depends = python-colorama
+ depends = python-matplotlib
+ depends = python-asn1crypto
+ depends = python-click
+ depends = python-pydot
diff --git a/PKGBUILD b/PKGBUILD
index 7e454ac1f2cb..3c03a712d74e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=("python2-androguard" python-androguard)
pkgbase=python2-androguard
pkgver=3.3.5
-pkgrel=1
+pkgrel=2
pkgdesc="Python framework for Android application analysis."
arch=("any")
url="https://github.com/androguard/androguard/"
@@ -14,39 +14,13 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/androguard/androguard/archi
md5sums=('903bd3b46cdd677757227edbd652a455')
package_python2-androguard() {
- depends=("python2" "python2-setuptools")
- optdepends=(
- "ipython2: interactive analysis support"
- "python2-pygments: color support"
- #"pydot: CFG support"
- "python2-magic: file identification support"
- "sparsehash: elsim support"
- "muparser: elsim support"
- "snappy: elsim support"
- "bzip2: elsim support"
- "zlib: elsim support"
- #"psyco2-svn: acceleration support"
- "python2-pyside: GUI"
- )
+ depends=("python2" "python2-setuptools" "ipython2<6" "python2-future" "python2-networkx" "python2-pygments" "python2-colorama" "python2-matplotlib" "python2-asn1crypto" "python2-click" "python2-pydot")
cd "$srcdir/androguard-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1
}
package_python-androguard() {
- depends=("python" "python-setuptools")
- optdepends=(
- "ipython: interactive analysis support"
- "python-pygments: color support"
- #"pydot: CFG support"
- "python-magic: file identification support"
- "sparsehash: elsim support"
- "muparser: elsim support"
- "snappy: elsim support"
- "bzip2: elsim support"
- "zlib: elsim support"
- #"psyco-svn: acceleration support"
- "python-pyside: GUI"
- )
+ depends=("python" "python-setuptools" "ipython" "python-future" "python-networkx" "python-pygments" "python-lxml" "python-colorama" "python-matplotlib" "python-asn1crypto" "python-click" "python-pydot")
cd "$srcdir/androguard-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1