summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9cd147e7243
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-astroml
+ pkgdesc = AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib.
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://www.astroml.org/
+ arch = any
+ license = BSD-3-Clause
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-scikit-learn
+ depends = python2-matplotlib
+ optdepends = astroml-examples
+ conflicts = python2-astroml-git
+ source = https://pypi.python.org/packages/source/a/astroML/astroML-0.3.tar.gz
+ md5sums = 56d5c281ca079eb569ef1898be1604db
+
+pkgname = python2-astroml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2b170be2a31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Quan Guo <guotsuan@gmail.com>
+
+pkgname=python2-astroml
+_pkgname=astroML
+pkgver=0.3
+pkgrel=1
+pkgdesc="AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib."
+
+url='http://www.astroml.org/'
+arch=('any')
+license=('BSD-3-Clause')
+depends=('python2-numpy' 'python2-scipy' 'python2-scikit-learn'
+ 'python2-matplotlib')
+
+optdepends=('astroml-examples')
+conflicts=('python2-astroml-git')
+
+source=("https://pypi.python.org/packages/source/a/astroML/astroML-${pkgver}.tar.gz")
+md5sums=('56d5c281ca079eb569ef1898be1604db')
+
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 ./setup.py install --root="${pkgdir}" --prefix=/usr
+}