summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f456d3a84bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-astroml-addons-git
+ pkgdesc = AstroML addons package contains addon code for the astroML package. AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib.
+ pkgver = 2013.12.11.gb6d3e97
+ pkgrel = 1
+ url = http://www.astroml.org/
+ arch = any
+ license = BSD-3-Clause
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-scikit-learn
+ depends = python2-matplotlib
+ depends = python2
+ depends = python2-pyfits
+ source = git+https://github.com/astroML/astroML_addons.git
+ md5sums = SKIP
+
+pkgname = python2-astroml-addons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91314f420d6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Quan Guo <guotsuan@gmail.com>
+
+pkgname=python2-astroml-addons-git
+_pkgname=astroML_addons
+pkgver=2013.12.11.gb6d3e97
+pkgrel=1
+pkgdesc="AstroML addons package contains addon code for the astroML package. AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib."
+
+url='http://www.astroml.org/'
+arch=('any')
+license=('BSD-3-Clause')
+depends=('python2-numpy' 'python2-scipy' 'python2-scikit-learn'
+ 'python2-matplotlib' 'python2' 'python2-pyfits')
+
+source=("git+https://github.com/astroML/${_pkgname}.git")
+
+
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python2 ./setup.py install --root="${pkgdir}" --prefix=/usr
+ #python2 ./setup_addons.py install --root="${pkgdir}" --prefix=/usr
+ #install -dm755 ${pkgdir}/usr/share/astroML/examples/{algorithms,datasets,learning}
+ #install -D -m644 examples/algorithms/* \
+ #${pkgdir}/usr/share/astroML/examples/algorithms
+ #install -D -m644 examples/datasets/* \
+ #${pkgdir}/usr/share/astroML/examples/datasets
+ #install -D -m644 examples/learning/* \
+ #${pkgdir}/usr/share/astroML/examples/learning
+ #install -D -m644 examples/README.rst ${pkgdir}/usr/share/astroML/examples
+
+}