summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--python-version.patch63
3 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..420140b282ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python2-claripy
+ pkgdesc = An abstraction layer for constraint solvers
+ pkgver = 7.7.9.21
+ pkgrel = 1
+ url = https://github.com/angr/claripy
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-ana
+ depends = python2-future
+ depends = python2-z3-solver
+ source = https://pypi.python.org/packages/b1/ab/323241b2f6ccb97828aa8221579905391d3103d4b45fba3c3d35fb244fc1/claripy-7.7.9.21.tar.gz
+ source = https://raw.githubusercontent.com/angr/claripy/master/LICENSE
+ source = python-version.patch
+ md5sums = 0e2c8246e8b23849b5e97d4a0e9dc30e
+ md5sums = 92da168ebb0065f567f0ea48bed0f512
+ md5sums = 71519b586ac229fd40597714e1f66b85
+
+pkgname = python2-claripy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ebf66308bc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Automatically generated by pip2arch on 2017-11-21
+
+# Maintainer: oneup <oneup40 at gmail dot com>
+
+pkgname=python2-claripy
+pkgver=7.7.9.21
+pkgrel=1
+pkgdesc="An abstraction layer for constraint solvers"
+url="https://github.com/angr/claripy"
+depends=('python2' 'python2-ana' 'python2-future' 'python2-z3-solver')
+makedepends=('python2-distribute' )
+license=('BSD')
+arch=('any')
+source=('https://pypi.python.org/packages/b1/ab/323241b2f6ccb97828aa8221579905391d3103d4b45fba3c3d35fb244fc1/claripy-7.7.9.21.tar.gz'
+ 'https://raw.githubusercontent.com/angr/claripy/master/LICENSE'
+ 'python-version.patch')
+md5sums=('0e2c8246e8b23849b5e97d4a0e9dc30e'
+ '92da168ebb0065f567f0ea48bed0f512'
+ '71519b586ac229fd40597714e1f66b85')
+
+build() {
+ cd $srcdir/claripy-7.7.9.21
+ patch -p1 < $srcdir/python-version.patch
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/claripy-7.7.9.21
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 $srcdir/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/python-version.patch b/python-version.patch
new file mode 100644
index 000000000000..ed8b53c6099f
--- /dev/null
+++ b/python-version.patch
@@ -0,0 +1,63 @@
+diff -ura claripy-7.7.9.21.orig/claripy/frontend_mixins/constraint_expansion_mixin.py claripy-7.7.9.21.new/claripy/frontend_mixins/constraint_expansion_mixin.py
+--- claripy-7.7.9.21.orig/claripy/frontend_mixins/constraint_expansion_mixin.py 2017-11-21 12:34:44.443988338 -0500
++++ claripy-7.7.9.21.new/claripy/frontend_mixins/constraint_expansion_mixin.py 2017-11-21 12:34:46.745893350 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import logging
+ l = logging.getLogger("claripy.frontends.cache_mixin")
+diff -ura claripy-7.7.9.21.orig/claripy/frontend.py claripy-7.7.9.21.new/claripy/frontend.py
+--- claripy-7.7.9.21.orig/claripy/frontend.py 2017-11-21 12:34:44.437304730 -0500
++++ claripy-7.7.9.21.new/claripy/frontend.py 2017-11-21 12:34:46.762594396 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import logging
+ import numbers
+diff -ura claripy-7.7.9.21.orig/claripy/frontends/constrained_frontend.py claripy-7.7.9.21.new/claripy/frontends/constrained_frontend.py
+--- claripy-7.7.9.21.orig/claripy/frontends/constrained_frontend.py 2017-11-21 12:34:44.443988338 -0500
++++ claripy-7.7.9.21.new/claripy/frontends/constrained_frontend.py 2017-11-21 12:34:46.749233559 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import logging
+
+diff -ura claripy-7.7.9.21.orig/claripy/frontends/hybrid_frontend.py claripy-7.7.9.21.new/claripy/frontends/hybrid_frontend.py
+--- claripy-7.7.9.21.orig/claripy/frontends/hybrid_frontend.py 2017-11-21 12:34:44.443988338 -0500
++++ claripy-7.7.9.21.new/claripy/frontends/hybrid_frontend.py 2017-11-21 12:34:46.749233559 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import logging
+
+diff -ura claripy-7.7.9.21.orig/claripy/frontends/light_frontend.py claripy-7.7.9.21.new/claripy/frontends/light_frontend.py
+--- claripy-7.7.9.21.orig/claripy/frontends/light_frontend.py 2017-11-21 12:34:44.443988338 -0500
++++ claripy-7.7.9.21.new/claripy/frontends/light_frontend.py 2017-11-21 12:34:46.749233559 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import logging
+ l = logging.getLogger("claripy.frontends.light_frontend")
+diff -ura claripy-7.7.9.21.orig/claripy/frontends/replacement_frontend.py claripy-7.7.9.21.new/claripy/frontends/replacement_frontend.py
+--- claripy-7.7.9.21.orig/claripy/frontends/replacement_frontend.py 2017-11-21 12:34:44.443988338 -0500
++++ claripy-7.7.9.21.new/claripy/frontends/replacement_frontend.py 2017-11-21 12:34:46.749233559 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import logging
+ import numbers
+diff -ura claripy-7.7.9.21.orig/claripy/__init__.py claripy-7.7.9.21.new/claripy/__init__.py
+--- claripy-7.7.9.21.orig/claripy/__init__.py 2017-11-21 12:34:44.450671947 -0500
++++ claripy-7.7.9.21.new/claripy/__init__.py 2017-11-21 12:34:46.762594396 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # pylint: disable=F0401,W0401,W0603,
+
+ import os