summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06985d182d0f..4b7943f27259 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python2-clize
pkgdesc = This decorator will turn your normal python functions into proper shell commands
- pkgver = 2.4
- pkgrel = 2
+ pkgver = 3.0
+ pkgrel = 1
url = https://pypi.python.org/pypi/clize/
arch = any
license = MIT
- checkdepends = python2-nose
depends = python2
- source = http://pypi.python.org/packages/source/c/clize/clize-2.4.tar.gz
- md5sums = 150f161299c95e314fba68a7b4ed49dc
+ depends = python2-sigtools
+ source = http://pypi.python.org/packages/source/c/clize/clize-3.0.tar.gz
+ sha256sums = 158e3251106fa9c2dfe414a3fea0c07eecb15b5be6ddf68a7cf73402081c79f6
pkgname = python2-clize
diff --git a/PKGBUILD b/PKGBUILD
index da61fae089a9..7a6d0541780e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,19 @@
# Maintainer: Francois Boulogne <fboulogne at april dot org>
pkgname=python2-clize
-pkgver=2.4
-pkgrel=2
+pkgver=3.0
+pkgrel=1
pkgdesc="This decorator will turn your normal python functions into proper shell commands"
arch=('any')
url="https://pypi.python.org/pypi/clize/"
license=('MIT')
-depends=('python2')
-checkdepends=('python2-nose')
+depends=('python2' 'python2-sigtools')
source=(http://pypi.python.org/packages/source/c/clize/clize-${pkgver}.tar.gz)
-md5sums=('150f161299c95e314fba68a7b4ed49dc')
-
-
-check() {
- cd "$srcdir/clize-$pkgver"
- ln -s "$srcdir/clize-$pkgver/clize.py" test
- python2 test/tests.py
-}
+sha256sums=('158e3251106fa9c2dfe414a3fea0c07eecb15b5be6ddf68a7cf73402081c79f6')
package() {
cd "$srcdir/clize-$pkgver"
- python2 setup.py install --root="${pkgdir}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
}
# vim:ts=2:sw=2:et: