summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 23 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49cf150a743c..0fd2c21cc5bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun May 27 21:04:09 UTC 2018
pkgbase = python2-coloredlogs
- pkgdesc = Colored stream handler for the logging module
- pkgver = 5.0
+ pkgdesc = Colored stream handler for Python's logging module
+ pkgver = 10.0
pkgrel = 1
- url = https://github.com/xolox/python-coloredlogs
+ url = https://coloredlogs.readthedocs.io
arch = any
license = MIT
makedepends = python2-setuptools
depends = python2
depends = python2-humanfriendly
- provides = coloredlogs
- provides = python2-coloredlogs
- conflicts = coloredlogs
+ depends = python2-monotonic
options = !emptydirs
- source = https://pypi.python.org/packages/source/c/coloredlogs/coloredlogs-5.0.tar.gz
- md5sums = f458e58fd7c0a429c4ff4437dedf658c
- sha256sums = 612354a11acd2e1d603c24fe7be21d736c53a23ad27f244cd9e3fdb4a99661d4
+ source = https://files.pythonhosted.org/packages/63/09/1da37a51b232eaf9707919123b2413662e95edd50bace5353a548910eb9d/coloredlogs-10.0.tar.gz
+ sha256sums = b869a2dda3fa88154b9dd850e27828d8755bfab5a838a1c97fbc850c6e377c36
+ sha512sums = f4a51fd8fa92ea4e2ef0b58305dcc4bbe12851e722fc85cfd4f48a9388002efced52bcf027f6dc4c525b095f3f953970e73928fdce3245ab4f9d13ae36b9d498
pkgname = python2-coloredlogs
diff --git a/PKGBUILD b/PKGBUILD
index 82d8e740137c..d7c679e5aa27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,21 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Jean Lucas <jean@4ray.co>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=python2-coloredlogs
-pkgver=5.0
+pkgver=10.0
pkgrel=1
-pkgdesc="Colored stream handler for the logging module"
-arch=('any')
-depends=('python2' 'python2-humanfriendly')
-makedepends=('python2-setuptools')
-url="https://github.com/xolox/python-coloredlogs"
-license=('MIT')
+pkgdesc="Colored stream handler for Python's logging module"
+arch=(any)
+url='https://coloredlogs.readthedocs.io'
+license=(MIT)
+depends=(python2 python2-humanfriendly python2-monotonic)
+makedepends=(python2-setuptools)
options=(!emptydirs)
-source=(https://pypi.python.org/packages/source/c/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
-md5sums=('f458e58fd7c0a429c4ff4437dedf658c')
-sha256sums=('612354a11acd2e1d603c24fe7be21d736c53a23ad27f244cd9e3fdb4a99661d4')
-provides=('coloredlogs' 'python2-coloredlogs')
-conflicts=('coloredlogs')
-
-build() {
- cd "$srcdir/${pkgname#python2-}-$pkgver"
-
- msg2 'Building...'
- python2 setup.py build
-}
+source=(https://files.pythonhosted.org/packages/63/09/1da37a51b232eaf9707919123b2413662e95edd50bace5353a548910eb9d/coloredlogs-$pkgver.tar.gz)
+sha256sums=(b869a2dda3fa88154b9dd850e27828d8755bfab5a838a1c97fbc850c6e377c36)
+sha512sums=(f4a51fd8fa92ea4e2ef0b58305dcc4bbe12851e722fc85cfd4f48a9388002efced52bcf027f6dc4c525b095f3f953970e73928fdce3245ab4f9d13ae36b9d498)
package() {
- cd "$srcdir/${pkgname#python2-}-$pkgver"
-
- msg2 'Installing...'
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd $srcdir/coloredlogs-$pkgver
+ python2 setup.py install --root=$pkgdir --optimize=1
}