summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c232b1efffc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-commando-git
+ pkgdesc = A simple wrapper for argparse that allows commands and arguments to be defined declaratively using decorators.
+ pkgver = r30.78dc9f2
+ pkgrel = 1
+ url = https://github.com/hyde/commando
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ makedepends = git
+ depends = python2
+ provides = python2-commando
+ conflicts = python2-commando
+ options = !emptydirs
+ source = python2-commando::git+https://github.com/hyde/commando
+ md5sums = SKIP
+
+pkgname = python2-commando-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0611ee3fa6ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christian Mauderer <oss@c-mauderer.de>
+pkgname=python2-commando-git
+pkgver=r30.78dc9f2
+pkgrel=1
+pkgdesc="A simple wrapper for argparse that allows commands and arguments to be defined declaratively using decorators."
+arch=('any')
+url="https://github.com/hyde/commando"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-distribute' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=(!emptydirs)
+source=("${pkgname%-git}::git+https://github.com/hyde/commando")
+md5sums=('SKIP')
+
+_gitroot=https://github.com/hyde/commando
+_gitname=python2-commando
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: