summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41dc0bfc9f62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Sun May 3 21:28:10 UTC 2015
+pkgbase = python2-diethack
+ pkgdesc = Diet problem solver with Dietary Reference Intakes in mind.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.diethack.org
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = python2-setuptools
+ makedepends = unzip
+ depends = glpk
+ depends = python2
+ source = git+https://github.com/diethack/diethack#tag=1.0.0
+ source = https://www.ars.usda.gov/SP2UserFiles/Place/80400525/Data/SR27/dnload/sr27asc.zip
+ md5sums = SKIP
+ md5sums = 74ed79e23e2eefc019bcebd34e9d4228
+
+pkgname = python2-diethack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42deac12a1f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Oleg Plakhotniuk <olegus8@gmail.com>
+pkgname=python2-diethack
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Diet problem solver with Dietary Reference Intakes in mind."
+arch=('any')
+url="http://www.diethack.org"
+license=('custom')
+depends=('glpk' 'python2')
+makedepends=('git' 'python2-setuptools' 'unzip')
+source=("git+https://github.com/diethack/diethack#tag=${pkgver}"
+ 'https://www.ars.usda.gov/SP2UserFiles/Place/80400525/Data/SR27/dnload/sr27asc.zip')
+md5sums=('SKIP'
+ '74ed79e23e2eefc019bcebd34e9d4228')
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/{,doc/,licenses/}"$pkgname"
+ cp -r "$srcdir/diethack/src/examples" "$pkgdir/usr/share/$pkgname"
+ cp "$srcdir/diethack/README.md" "$pkgdir/usr/share/doc/$pkgname"
+ cp "$srcdir/diethack/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+
+ cd "$srcdir/diethack/src"
+ unzip "$srcdir/sr27asc.zip" -d diethack/nndb
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}